BLE + Location Issue

Greetings to the whole community, I’m new to thunkable and I’m referring to this post because it has the same thread as my problem. My project consists of getting the LED turned on on an esp 32 via thunkable App button command obviously via BLE connection, my project does not proceed because I receive an error of “BLE component request permission to access location sensor.” 1 I have enabled App thunkable GPS permissions in my Android phone. 2 I added GPS sensor to my project and every time I press the button I receive the coordinates of my position in my project. 3 with third party App I detect my esp32 name, MAC, UUID characteristic. I have read a lot of documents about it and seen many video tutorials but I have not been able to find the solution, I ask for help from those who have faced and solved this problem. A good day everyone.

Hello @vico3341rys8kx welcome to the community
The topic that you originally posted this issue is 4 years old so we split this off into this new topic here.
How did you test it? Did you use the Thunkable Live App, APK or AAB?
Could you please share a screenshot of your blocks?

2 Likes

Many thanks for your interest Ioannis, these are the blocks I used, I’m using the Thunkable Live app but I also tried to download the test APK but nothing, the problem remains the same, I inserted a position sensor in the blocks which provides me with the my coordinates successfully but when I SCAN the BLE devices the error message is that the BLE component requires permission to access the localization sensor, on my smartphone I have allowed permissions in the thunkable app but the device cannot find anything.

Hello @vico3341rys8kx
Thank you for sharing more information
I tried to replicate the issue but I couldn’t
Are you sure that there are devices in your area?
Which device and Android version did you use to test it?

ciao @ioannis I’ll update you on my progress, I configured the blocks as below and I managed to connect to my BLE device, there was no need to have the position sensor integrated into my project, I only identified the MAC ADDRESS dl my device with a 3rd party Android application that detects BLE devices and also lets you see UUID addresses, I entered the MAC ADDRESS in the BLE connect to device ID block and I obtained the connection to my BLE device. I was unable to SCAN the devices in any way. I don’t understand where I’m wrong or where the problem lies. I would have liked to integrate the scanner function into my project.

1 Like