App crashes on open

I had my app nearly finished and working properly in both android and iPhone then all of a sudden it just crashed. Now when I log either phone in, the first screen opens for a few seconds, and then shuts down completely. Cannot do anything. I think it may be to do with Alert, 'cos that’s the last thing I changed. Took it out on the browser but remains the same. Waited all day just in case it was the server 'cos sometimes I get lag between changes in the browser and changes on the phone. Today not working…

How big is your application? How many screens are there in it? The application is broken on iOS and Android?

App is about 12Mb and has 4 screens. I just tried to load your app for a bit of learning, and it did the same. Got me completely stumped. Have uninstalled and reinstalled the Live app. Cleared the caches on both browser and app. Don’t know what to do…Yes, both the same on Droid and iPad.

Try to run this version 7.25.18

Does this version work for you?

I was faced with the fact that when you reach a certain size of the application it just does not start on my Android, but works on my iPhone 5 and 6. According to Mark, there is a 1MB limitation on the size of components + blocks + code.

At me occurs so: I launch the working project on Android, then I add in it 1 screen with a pair of components and all the rhinestone collapses so that I can not understand the error.

Couldn’t get to your app 'cos I was locked into open crash close. So just as a hunch I went and removed all the alerts from my app and PRESTO!!! it started working again. As you know I’ve had trouble with Alerts, and thought I had found the problem, but obviously not. What I will do, is start to put them back in one by one and see what happens. I’ll get back to you. And thanks for the help.

It’s nearly midnight here in Oz, so i’ll look at your app in the morning…:upside_down_face:

I downloaded and installed your App on my droid. It installed and worked ok. I started to work through the different screens until I hit one of the bugs you know about. There is no problem with restarting the App, whereby it seems to refresh the problem and works ok. Hope this helps.

I apologise for my late response, but I was called away yesterday…:smirk:

Thank you for the information. It looks like version 7.25.18 is more or less working.