Airtable "null" issue

I am trying to use Airtable to store account information of different users. I’ve tried to test it with multiple devices, and although it worked for a few cases, it stores the “username” field as “null” even when there is data input from the app most of the time.

The blocks concerned are under the Button2 Click event:
Is there anyway to resolve this?

Hi, @renren66! :wave:

My Chrome cannot open your project :confused:
(It’s just loading a blank image with lots of orange, yellow ochre blocks)
It seems you have used a lot of variables, that makes your project crash on mine…

:arrow_right: So Can you please provide a screenshot of your blocks of button2?

Thanks! :blush:

Your blocks in very complicated and duplicated - Alert bunch, bunch of action, some obscure check for null.

In programming, there is a recommendation - in every function you should try to perform only one operation, because the more complex the function, the much more difficult to look at her mistakes. Throw bugs Thukable X and will be very difficult to understand where your mistakes, and where the system error. For this reason, as variables I use function blocks and parameters only in case of emergency use global variables.

Create a simple function check, create a new row to be accurate or not.

If the database is recorded null, it means that the stored-block is not initialized (it nothing was written) or for whatever reasons, null is written in it. Blocks of global variables become unstable and I would not be surprised if it’s a bug system. For this reason, as variables I use function blocks parameters and only in case of emergency use global variables.

1 Like

Why working with Thunkable X (and not only), you need to check everything and do not trust your eyes?

I give a simple example.


Label1.Text “undefined” display on screen, and how many characters will return the block length of?

Another example - screen component has such a configuration


Does this mean that the padding on Android are equal to 0? No! But how can this be, we’re seeing 0 in the fields! You can draw anything you like, but this does not mean that it is in reality.

1 Like