Airtable Bug Noticed

Hello thunkers,
I have noticed that in the beta version of thunkable, airtable writes values as empty when called using create blocks.
However in the older version of thunkable it writes values correctly.
This is bad for me because i have already gone far in designing an app using the beta version.
Screenshots below:

This was done using the older version

This is the beta version as you can see it is empty

Please this is a very bad bug that i noticed since last week. I thought it was only because of the updates but it is still persistent.
@jane
@domhnallohanlon

1 Like

@muneer
@actech
@tatiang
please help

1 Like

Thank you for making us aware. Can you please share a link to a project that demonstrates this case in the DnD version?

1 Like

Ok sir.
https://x.thunkable.com/projectPage/61921e85932fe6001110c585

1 Like

It is obvious that you are using number of fields in your Airtable table. It is also unfortunate that once a project if copied, the table is converted to a local table and therefore I am unable to check fields type or conduct the test.

Please note that Airtable enforces preliminary checks before creating the new row. For example, if the column is of Email then you cannot pass a text that does not contain @ ..

Can you check that your text that is being passed to the create row block actually matches the column type?

Yes it does

1 Like


See the red circle. This will not be allowed in the new design.

I did not create a data field type in airtable as all fields are short text

1 Like

Are you able to share the table so I can do the test directly on it?

The Data Source blocks has issue with types of columns and null values.

I’ll pm you now sir

1 Like

You are correct. There is a BUG

This bug is not in Airtable or any part of the code.

Please check your Airtable table and see that I have used your code to add more rows.

The problem is with the Preview Button. Nothing works when using the preview inside the designer or blocks screen.

But will I run the project from this
image

It worked fine.

Happy Thunking!

1 Like