Video component does not play sound (iOS only) - edited

I can remember weakly that we had this issue before, but I could not find any hints in this forum here. Here is my issue:

  • I made an app that contains the video player component. No other media component is used (e.g. sound player).
  • When pressing a button the video component shows up (visibility=true, play=true), an external file is used as the video source and the video starts to play.
  • on Android: video and sound play, on iOS there is no sound.
  • the iPhone (Type 6S, iOS 14.2) is able to play the video with sound when I point it directly to the cloud storage, where the file resides. The file has the suffix “.mp4” and is 3MB in size.
  • I searched all settings in iOS: sound permissions are set for thunkable and for the app.
  • there is no sound, neither in the live companion (version 243-5) nor in a downloaded iOS app.
  • the iPhone is not muted, the volume is set to a reasonable value.
  • for testing purposes I made a very simple app: just the video component and a button, that sets when clicked. Still no sound.

Edit: I think I found the source of this issue. If I’m right this can only be solved by thunkable staff (Hi @Steven), would you please be so kind and have a look:

  • my app produces sound while playing a video, but only on the headphone output! I tested my iPhone with Deezer and the sound can be heared by the speakers and it switches when inserting the headphone jack. My thunkable app does not switch, it always plays the sound on the headphone. That’s why I thought at first that there is no sound, because Thunkable only plays on headphones.

May I assume that iOS manages an array of possible sound outputs (let’s say headphones, speakers, bluetooth) and other apps like deezer or so switch the output when the user inserts or removes a headphone jack. This is maybe the missing part in thunkable: in iOS live / iOS downloaded it does not switch from headphones to speakers.

I hope this helps to solve this issue. Maybe other components (speech synthesis, …) are also affected by this?

Thanks, we will look into it. If anyone else is seeing the same issue, please reply and let us know!

1 Like

I am also seeing this issue on IOS. Sound was working but stopped a few days ago. Try this app as proof of no sound on IOS. Thunkable

Thanks @rwplummer1yf4f

Is this on live testing or installing or both?

Both. Works on android though.