Unable to fetch result of a api ticker


i am using an api ticker. link below.


when i try to get the details it gives me an error
can anyone please help me

what do you mean do i need to do something here

You know, it’s weird. I’m wondering if there’s some kind of request rate limit. I was able to produce a response about 3-4 times and then it wouldn’t Produce a response.

Have you checked the error block?

What’s more weird is that it still works on my chrome browser on my Mac every time I press reload.

1 Like

See this fix

Screen Shot 2020-03-28 at 10.32.27 AM

very strange, but, i got some kind of error on my first app. so i deleted it and remade it. then it worked


then i got an error…

i cant seem to manage this like a regular json object. idk whats wrong. i cant get object properties

i also now cant

and now i can. it keeps working. then not working

there are only two properties of the main object but i cant get them with blocks the normal way. also, it’s a huge text file returned. 120000 characters. i wonder if this is a limit issue?
this is a pretty formatted version of the what the api returns.
jsonformatter.txt (125.0 KB)
info on that text file

okk, i’ve made some progress

ive gotten as far as seeing properties of subproperties of markets. but it keeps making the app crash. the data returned is so massive!

finally i got somewhere. I am able to list out all active coins on the market-status ticker
it’s a little odd but here you go! I have to first get only the ‘markets’ and then put that into a loop and create a list of items. then go through the list 1 by 1 and get the info needed.


Ok, try this

This shoud list the coins that have info. if you click on any item, you will see how many times it is in the list. Does this api provide info bot current and the last known measure?

That was a little tougher than the other apis I’ve worked with! Thanks for the challenge! I hope my block example will be useful on how to extract information from this api.

1 Like

@videshi.in.germanydr, were you ever able to get the API to work at all?

1 Like

The data is not showing up when i click on Live Test.

what kind of device are you using? It really feels like a performances issue. even on my iphone it was lagging.

I am using Google Pixel 3