Trouble sending my app from Thunkable to Apple

Dear Thunkable staff,

unfortunately Apple refused the application that i upload with Thunkable.
They wrote me an email:

App Store Connect

Dear Developer,

We identified one or more issues with a recent delivery for your app, “BOLOGNA MEDIEVALE Culture Art”. Please correct the following issues, then upload again.

Invalid Signature - A sealed resource is missing or invalid. The file at path [] is not properly signed. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose “Clean All” in Xcode, delete the “build” directory in the Finder, and rebuild your release target. For more information, please consult

Best regards,

The App Store Team

I already updated this app about 15 days ago without any problem, and in this update I followed the link of the Thunkable video instruction to send an app to app store connect, step by step, and I uploaded all the correct certificates.Thunkable tell me everything is ok and i received an email from Thunkable that told me that my app was sent correctly to the Apple Store but then few minutes Apple send me an email about always the same reject.
I have tried several times also inserting all the certificates again but it always gives me the same error.

Thank you for your help,

Hi @Francesco_Veratti,

We’ve made quite a few updates recently, let me double check with the team and make sure that nothing has changed in the publishing process.

Are you using the same .certSigningRequest and .mobileProvisioning to update or ate you generating new ones?

1 Like

Dear @domhnallohanlon
Can I use my own .certSigningRequest ?

Hello Domhall,

Thanks for your reply.

I tried three times with creating new certificates(.certSigningRequest e .mobileProvisioning).
I think the problem is due to your internal updates.

Thank you for your work,


Delete all certificate and provisioning. After than watch this video.

Hello Doctor_Soft,

Thanks for your reply.

Yes, I already deleted the .certSigningRequest and .mobileProvisioning and created a new one .certSigningRequest and .mobileProvisioning but unfortunately it still does not work.

Thank you,


Did you open 2FA. You have to open 2FA. You can add phone number for appleid too.
And watch this video step by step. It will solve. Because i did.

Thank you for your help.

In these days I have often loaded some builds (with 2FA opened)
and I have never had any problems, so I think it is not my problem but a problem of thunkable plattform update.

But i uploaded new version last night.

Maybe the problem is in the structure of my apps.
Even in the past I had similar problems, I created applications with many functions and when they update the Thunkable platform it happens that I have problems with my apps update. The Thunkable staff does a great and huge job and I think that some setbacks are physiological, I’m sure that in a short time they will solve everything!