[Solved] Error uploading App Store Certificate

I want to publish my application for the first time in ios, I already have a developer account, and I followed several tutorials but I still can’t publish, someone could help me. Thanks

this error I get

You need to generate and upload an ios_distribution.cer file from your developer account. When you get into your developer account, click on Certificates. If you haven’t created one yet, click on the blue and white + next to certificates and then select iOS Distribution. Then, follow the wizard to complete creating your certificate. You will also need to create an app profile for the next step. I followed the iOS publishing guide here on Thunkable and had no issues creating either for my app.

Here’s the guide:


1 Like

Error trying to send update to applestoreconnect. Uploading the provisioning profile redirects to “thunkable.com/externalerror”.

I’m trying to update the corrupted applications from the problems with the blocks used from “Data source” and now I get this error when trying to upload the updates to the app store.

Error since 07/14/2021, tried from Mac OS and from Windows, from different browsers, browser cache was cleared and persists. The error occurs when uploading the provisioning profile.

i confirm this

I’m with the almost same issue! But it’s occurs one step before, when I try to upload the distribution certificate.

Hey @fredyfernando,

Thanks for flagging this. We pushed an update last night which should resolve this issue.

Can you try publishing again and confirm that this is working for you again?

cc: @zimat.bed9ut @lamagalhaes


It’s fixed!

1 Like

I have the same problem

I am using the CSR that is provided by thunkable to create a distribution certificate. However, when I come back to download the distribution certificate to thunkable I get this.

I am stuck at this point in the process. Any thoughts or ideas would be greatly appreciated. I have seen this problem listed before, but I did not see any solution.

Thank you,


Ok, be careful when following the video. The screens look different now. Make sure to select

*** Sign your IOS app for submission to the App Store or for Ad Hoc distribution****

This seemed to work for me, so I hope this helps you.

I have a problem to publish my app to appstore.
The App is well published to playstore and I test it on iphone without problem.
when i try to upload the file of my distrubition i get this message

This has been discussed multiple Times.
Please search the community first.
Thank you

I didnt find

I found three other topics and merged them all into one.

Looking at your error screen though @thunkdevi7 it seems like this isn’t the same as the error we fixed last week (hopefully!)

To start, can you try a hard refresh as see if that works for you?


i try 2 days still the problems

I have some problems I talk with the support team no reply

@domhnallohanlon unfortunately, this issue has returned!

Thanks @lamagalhaes (and @thunkdevi7)

It seems that the error is very similar to the previous issue (hence my initial confusion) but the underlying issue is slightly different.

We’ve flagged this with the team and hope to get a fix out shortly.

Will update this thread when it gets out.

1 Like

Okey Thank You :slight_smile:

This should be resolved now. Thanks everyone for waiting, and shout out for @domhnallohanlon and @wei for the good work!