Thunkuble live critical error on phone - data grid

Hey everyone,
i have a question about my app crushing while live testing on my phone.
I have an app (Thunkable)
which is essentialy a tool for a offline traveling game of tag. (similar to show JetLeg for people who know it). I wanted to add a social aspect to it - i added shared libarary of images, where everyone can share their photos of them playing the game. The issue isnt in uploading the photos, but for some reason there is an issue while showing a grid view (page called “databáze fotografií” of all the posts - but only on mobile devices on computer everything seems to be working. The grid view is from data from google sheet where is saved a link an image on Cloudinary, a short description and a nickname of the author. I have seen similar issues on this comunity, however common ways to fix it like changing the databese view arent working. Any help with this matter is appreciated. Also i am a beginner at thunkable so i am sorry if there is any obvious solution.
Here is an image of the error log:

here is image of the database grid view completely working on a computer

here is image of google sheet (data source)

Hello @vachajosef19 welcome to the community.
Thank you for sharing your project.
Unfortunately, I can’t replicate this issue on my device.
Is this happening only on Android?
Are you sure that you have the latest version of the Thunkable live app?

i have tried multiple things
i reinstalled thunkable live,
i created an apk build, but for some reason it still wasnt working.
Finally i tried it on a different phone and it worked without any issues, so i guess it is a problem in my phones os.
Thank you for your help

i have an update.
I have tried this app on multiple phones since than and it wasn’t working on multiple devices. It didn’t work on:
Motorola G54;
Xiaomi redmi note 10 pro;
However it did work on xiaomi redmi note 8t.
Does anyone have solution to this?
Maybe the problem could also be about android versions - so it works only on the older ones. @ioannis on which android version did you try that?
Thanks everyone for help

Hello @vachajosef19 :wave:
I am sorry for all the issues you are experiencing.
The device with which I tested has Android version 13.
Which are the Android versions on your devices?