Text input now squashes screen arrangement

Hi If someone out there could give me some help on this I would be really grateful;
The project Ive been working on for the last 6 months or so uses a text input in the centre of the screen arrangement with a row of buttons along the top and a row along the bottom.
I made the layout so the bottom row contains buttons for functions not relevant for use while text input is in use.
Up to a few days ago when the text input was opened the keyboard covered the bottom row of buttons.
I haven’t changed any settings or design elements but now when I live test
when the text input opens the keyboard pushes the bottom row of buttons up into the area above the keyboard
this squashes the arrangement
Even more of a problem when more than one line of text is input into the text box the first line is pushed up and hidden under the top row of buttons.


Is the keyboard moving the input field? Finally, the developers fixed the bug when it did not move! But it seems that it does not work as well as you would like.

Can you give a link to your project or show how everything is in your project?

Hi yes seems like when the keyboard pops up it pushes / squeezes the whole arrangement up above it. The strange thing is this just started happening a couple of days ago. Up to now the keyboard covered the lower elements of the arrangement which worked perfectly for me.
previously if the text input ran into more than one line it would just continue below leaving the first line still visible and the text readable as a whole.


Now the keyboard works more correctly. Previously, I created all the input fields only at the top of the screen, as it simply closed the input, which was just a nightmare.

The keyboard pulls up the work area upwards, so absolute positioning also does not allow the buttons to remain at the bottom. You can try using Botom Tab Navigator. I see on the Instagram registration screen how the “Button” button is pulled up by the keyboard from the bottom, and after closing the keyboard it jumps down - an unpleasant effect!

Thanks for getting back to me.
So is this a temporary problem that will be fixed and revert to the previous way of keyboard covering elements or it is peremnant and I need to change my settings somehow to get around this?

I think you need to change the solution with a button and use another solution instead. But work on the keyboard will continue, because not everything is working well with it. For example, after entering a line in a multi-field, my keyboard closes after each press of the return key — which is very inconvenient for entering multi-line text.

It is interesting that when opening the keyboard, the bottom edge of the page is not always pulled from its very bottom edge. It needs to be studied in more detail.

Thanks for your help. I think I could partly solve my problem if I could set the text from the input to continue below instead of pushing the previous line upwards. Do you have any idea what settings on the text input would do this?

I’ll think about what you can do here.

You have very complicated markup on Screen1. Can it be simplified?

yes I realise that but I think I need all of the elements on this screen.

I have now tried changing the layout with the text input field lower with space above to fit several lines but as soon as the text exceeds 1 line the first line is not visible anymore even if there is no element above for it to be obscured by. seems strange

I see a problem, but I don’t quite understand why you have such complicated markup on your screen and use so many empty buttons and labels. The harder the markup, the harder it will be to debug the screen.

Solution is vertical scroll arrangement. Try to put all screen componenets inside of the main vertical scroll arrangement

Thanks but this also doesn’t work for me. My understanding now is that the text input has been redesigned to avoid covering any of the elements on the screen. Unfortunately I designed my layout with the previous functionality of the text input. thanks for your help though :+1: