Suddenty the "find first accurance of item" dosent work right

I have 2 places in my app i use this block. And everything have worked before. And suddently it dossent work yesterday. It just stop there and dosent go on.
Very strange.

Exact same issue happened to me before but it was an if/else statement. I couldnt solve it so i waited a week and recompiled the exact same code again a week later and it worked. Im guessing thunkable server has some random glitches on this. Had this issue all the way back when thunkable X is in beta.

I really think this is a seriusly problem that Thunkable staff have to look in to. I have to completely same app. the one is a backup and that works fine.
I had a perfectly working app. And now nothing works. VERY confusing and no help from anyone…
And I am afraid to change anything since everything have wored perfect before…

1 Like

Display the value of all blocks on the screen in a red line area and then you will see the problem.

When working with Thunkable X, you can solve the same problem in several ways. The problem is that different solutions have different reliability. How can I find out how reliable different blocks work? Only in practice and thanks to their experience and knowledge.

What is the reason to it don’t work. I haven’t changed a thing???

Thunkable X is constantly updated and for this reason, something may stop working. There are 2 ways out of this situation, you can wait for an unknown amount of time when everything will work again, or find out the reason why it stopped working. There is a third option, but I will not voice it, since everyone can guess about it.