Suddenly app hangs when reading airtable linked fields

Hello everyone,
i suddenly have a problem with linked fields in an airtable. Without me changing anything my app doesn’t read linked fields anymore, it just hangs while reading, doesn’t come back. The app is running (without changes) for about 2 weeks in a group of people as beta for testing (ios & android). Suddenly, from one day to the other, it gets stuck while reading. I waited for one day because I was sure that it must be something external - I didn’t change anything in the app.
But after the error didn’t disappear again, I started testing and quickly noticed that if I deactivate the reading of the linked fields in the block editor, the app runs correctly again (of course without the contents of these fields). I am a little bit helpless what I can do. Has anyone else experienced this?

Hi @migo can you share a little more about what you did here please?

Hi @domhnallohanlon, thanks for looking into this issue.

Sure, it’s pretty easy to show and to explain. In my joinIT-App I store all the used data in airtable tables. Concrete example: The main-table is the “tb.ITteam”. In this table I have a couple of usual fields like firstname, lastname, shortcut, etc. And I have some linked fields like function and group. Function is linked to table “tb.function”, group is linked to table “”. I use this method to ensure, that values in the fields function and group (in table tb.ITteam) are crosschecked for validity in tb.function and Everything worked fine for ca. two weeks. Here is the block-snip where you can see how I read those fields:

You can see (No. 1 & 2): these are the linked fields, all others are unlinked fields.

Without me changing anything (not in the app, not in the tables) suddenly, my app hangs when reading 1 & 2. I am sure about the source of the problem, because a ran a test where I deactivated only the blocks 1 & 2 and everything ran fine (of course - without the values function and group). This happens on all platforms: on phones with iOS & Android, on web & in live-tests in the thunkable app.

Do you have any ideas about this case? Thanks a lot in advance!

I had similar issues with Google sheets in the spring of 2020. Deleting the data source, creating a new data source, and replacing all of the blocks was the solution. Going through that process every time thunkable modified the interface seemed like too steep a price, so I switched to firebase. I have not regretted the choice.

1 Like

I really hope (no, I’m convinced) that this is not the favored approach of the thunkable-team to keep apps up and alive which are already released and “in the field” ;).

I’m stucking here right in the middle of a beta-phase with users who have the app on their iOS- and android-phones. Urgently hoping that there is a solution.

1 Like

Unfortunately, I have not received any further answer to this problem until today. Dear @domhnallohanlon, did you have a look at this? Or is there someone else here in the forum (community, support, whoever) who can help? I have a really big problem when an app that is already rolled out suddenly stops working.
Thanks in advance!


Again an update on this issue: Here is what I got from the airtable support-team. Still hoping, that someone from thunkable-support will be able to help:

Thanks for reaching out, and I’m really sorry for the trouble here.

For context, third party integration programs like Thunkable interact with Airtable using our API. From this information, there isn’t enough context for me to know exactly what’s going on, but I assume some API calls to fetch this data from Airtable might be failing. I know you said you’ve already written to Thunkable’s support team, but would you be able to ask them for a log of the API requests they are making with any failure responses? Unfortunately we don’t keep a log on our end of all failed API requests, but they might. If you’re able to recover the contents of those API requests, as well as the error responses (if any) they are receiving from Airtable, that would be very helpful and I’ll be happy to look into those.

In the meantime, I would recommend the general troubleshooting tip of re-building this in Thunkable from scratch to see if something just became mid-configured.

I hope this helps – let me know if you’re able to get that information from Thunkable’s support team and I will be happy to look into it! However, given that this is a new issue you are seeing, I do think their support team might be able to help more in identifying what is going wrong

1 Like

Unfortunately, there is still no solution on this issue. Meanwhile I got some answers from thunkable-support, like “we will look into this” and “please try it now again, we changed something on the API”. As a workaround I meanwhile cleared the values in all linked fields, which is working, but of course, annoying cause reducing functionality (btw: I also removed the fields completely already and recreated them. As soon as I fill them with values all user-apps stop working. To me this is a very serious issue, because nobody can explain, what exactly makes my app stop working, while it is already rolled out to users. If I cannot rely on such a basic functionality (or at least on a support who is able to solve this within an acceptable time) I have to reconsider whether thunkable is my future development platform. I think you can read my disappointment.


Update on the issue:
Currently I’m in contact with the developers team via github. Who is interested and wants to follow this conversation will find it here:

1 Like

Who ever is interested in this case: I figured out a working solution today. See details in: Suddenly app hangs when reading airtable linked fields · Issue #764 · thunkable/thunkable-issues · GitHub

1 Like

This is solved :grinning: :+1:

Long story short: Airtable Linked-Fields are delivering arrays, not single values. It was a long trip to get this solved and Steven Purn from the developers team gave me an outstanding support via github.

If you need to know more details, you can enjoy the long story here :sweat_smile::