Spreadsheet 'Get All Data' crashes app

I have now tried multiple spreadsheets with data and empty ones to simply have a button activate the ‘Get All Data’ call. A few seconds after pressing the button the app just crashes.

Earlier today it seemed to work fine for a couple of hours though. Why is this happening?
I am able to upload data through the app - just not read it.

It is difficult to name the reason without viewing the application. During the last time you did not change anything in the project? Does this happen on Android?

1 Like

I indeed changed some stuff - however. Even when I try and make a completely fresh app - add 1 button and add the call.Spreadsheets1.Get All Data function it just crashes the app.

I assume it’s either the Spreadsheet extension problem or maybe a problem on the other end at cloudstitch. But I am not sure how to fix it. Or is there maybe a log somewhere that I am missing?

And I am using android yes.

Unfortunately, while Thunkable X for Android is unstable. You added a new component, block or changed the property after debugging the project and this can lead to crash.

To find errors more quickly, I recommend that you use the “adb logcat” debugger and look at logs file.

Hi @MuckYu,

In my experience this is the main cause of this error:

Hi @domhnallohanlon thanks for the suggestion. I went through my blocks and spreadsheet again and it seems that the LAT and LNG from the GPS coordinates are the issues. They are displayed with dots.
For example: “22.33944”

I tried to use the ‘Replace all text’ block to replace those dots with something else. However it does not seem to accept those. I always get an error such as:

The operation format as decimal cannot accept the arguments: , [22;33942], [5]
Note: You will not see another error reported for 5 seconds.

I tried multiple different characters such as: & A 1 _ - ? ! …

Any ideas how I could handle this?