[Solved] Where is Vietnamese in Text to Speech?

Hi guys, I just discovered a problem with the Text to Speech function in iOS for the Vietnamese Language. The app works fine on Android. In iOS, instead of reading out the words, it reads each letter of every word. I believe this is something that needs to be fixed in the bot itself. Can you check to see if there’s anything you can do to resolve this for me? Thank you!

Hi,

If you give me the blocks, then I can add this to my bug tracker with the help of which it will be possible to track the correction of this error. I’m afraid that I can’t help anything else.

Best regards, Alex
ACtech demo project
Thunkable X Basic Programming Course
Block Reference
Component Reference
Bug tracker
Polipaint
Map canvas
Method Inspector
Performance

Hi @hhuman,

This is not really a bug from Thunkable but caused by Apple not having support for voiceover / text-to-speech in Vietnamese:

Also in the Apple community somebody recently asked if the could please add it so I am pretty sure it is still not supported by the OS. Please, add Vietnamese voices to text-to-… - Apple Community

Best, Chris

2 Likes

Ooooh… got it. Thanks a lot for finding this out for me!