[Solved] Webviewer scrolling on Android

Hi everyone!

My web viewer is not working at all. It does work in a web preview, but it doesn’t scroll or tap in the live test or the published app.
Anyone else having issues like that? Am I missing something?

Can You please share your Project link?
Also, Welcome to the community, Keep thunking!

1 Like

Here is the link: Thunkable

It is very simple but for some reason is not working the way I want. Thank you!

1 Like

Nice looking app! I opened your app in Thunkable Live. I noticed that things grey out a little bit while scrolling, but it seems responsive to me and it does scroll. Testing on an iPhone, latest version of Thunkable Live. You might want to update your version of Live if you haven’t? What type of device are you testing on?

1 Like

Thank you! I am testing on an Android (PIxel 5)… Could this be an Android issue then? I have checked and I already have the latest version on Live on my Pixel… any other ideas?

1 Like

I just checked it on Android and it is not scrolling.

1 Like

First of All, Extremely beautiful app and loved the color scheme, Second, I am using an asus phone and it worked perfectly. hope the published app rocks.


1 Like

@anush_bh20910 @muneer Was this live testing or installing?

What version of Android/Thunkable Live are you using?

1 Like

The app is only a wrapper to a website. Thunkable app has nothing but a Web Viewer to https://www.rootsview.com.

I was able to enter data but not able to scroll the page in the Live Test mobile app. It works in the Web Live Test

It was live testing, @domhnallohanlon .
According to my knowledge, it’s android 7

I see this error when I open the app or the website, maybe this is the cause of the problem you mentioned:

1 Like

This is very possible and if the mobile user changed the default browser might see different effects.

Interesting… I have never had that error. Are you using the Live Test on Android as well?

You don’t see it because you probably use the browser (or the language set on your mobile phone) with the English language set, if you try with Italian you will see the errors:

Notice: The language 'it_IT' has to be added before it can be used. in 
/home/ztz9phn8fbsk/public_html/library/Zend/Translate/Adapter.php on line 443

Notice: No translation for the language 'it' available. in /home/ztz9phn8fbsk/public_html/library/Zend/Translate/Adapter.php on line 456

I suggest you to investigate about it because there may also be problems with other languages (as well as creating problems in the layout, with horizontal scrolling that cancels the responsive modality):
Zend Translate doesn’t find language


I will definitely do that! Thank you!

@domhnallohanlon I still haven’t been able to find a solution for this. Any ideas on what the problem might be?

Hi @marcus3u7 @anush_bh20910 @catsarisky @muneer,

We can see this behavior when testing an app that contains a Web Viewer on a device: the Web Viewer, and any other components on the screen, are greyed out. While this does not affect functionality on iOS, on Android, the user cannot scroll on the Web Viewer.

Thunkable team member Paul is working on this issue.

Thanks to all of you for reporting!


Thanks for the web viewer update, @jane. I also recently faced the same issue. Hope the update works.


1 Like

Awesome! Thank you for the update!

1 Like

Hey everyone, just letting you know this fix has been published. Thanks again for bringing this behavior to our attention promptly!