[Solved Sorting in Airtable

Hi All,

I have an app linked to an Airtable and until this afternoon it was working perfectly. However, now it seems that the items are displayed in chronological order they have been entered into the Airtable. For clarity: the first item displayed in my app is the oldest (in chronological order) included there. I have tried to use the filters but nothing seem working.

Anyone experiencing the same issue?


Can you share a little bit more about this issue? What blocks are you using to sort/filter/display the Airtable content?

What should the data look like in Thunkable and what does the data look like?

Sure @tatiang. The issue is not in the blocks used but in the data displayed. I simply use a data viewer to display the data linked to an airtable.

The data are a list of images and information of products.

To sort the data I created column in Airtable and I sort it 9 to 1 (to have the most recent entry at the top of the list).

I couldn’t get if this is an Airtable or a Thunkable issue. Indeed, when I sync the airtable in “my data sources” I can see the data as displayed in the app - but it doesn’t follow how the data are displayed in my airtable!

The data in my airtable are displayed in chronological order (most recent on top) - however, this seems not working anymore as from a few hours.

This is true. I have the same problem here. It’s not bec of blocks we used. Bec I’m using the same app for at least 3 months without a single update. But today dataviewer has a sort problem. Need fix or recovery. I dont know if it comes from thunkable or airtable.


Okay, I was able to replicate the issue. If I sort my Airtable data and even if I click the sync source button in Thunkable, when I preview in Thunkable Live or a browser, the data is unsorted.

I would recommend submitting this as a bug. I agree that it might be an issue with Airtable but it would be good to rule out Thunkable as the cause.

1 Like

That’s great! Thanks for sharing @bymaho

If anyone else is having the same issue it would be good if you can send a message here under this post. This would allow us to flag to the thunkable team that this is a REAL AND IMPORTANT ISSUE - this really needs to be fixed as soon as possible.


Hi everyone, thanks for reporting this, and thank you to @bymaho for sharing the link to the Airtable forums!

Since this seems to be an issue on Airtable’s end, we won’t be able to fix it ourselves. We’ll definitely keep up to date with Airtable’s response to this issue, and I can follow up here when this behavior has been resolved.


Update from Airtable team member Richard:

"Hi everyone, this should now be resolved. We detected the issue and made the fix on April 12, 2021. Thank you for the reports, and please let us know if you continue to see issues here.


@Tommaso @bymaho @tatiang does your Airtable data appear as expected now?


It is well. Thanks. Great job.

1 Like