[Solved] PDF viewer issue iOS?

I have just uploaded my updated app to the app store and have issues with it in test flight…particularly the PDF viewer. It worked perfectly on the live test online, and also in the live test app, and on the previous version of the app which is currently live.
When I open the PDF doc in test flight the app white screens and you have to close the app to do anything.
Can anyone shed some light on the topic please? :slightly_frowning_face:

Hey @steveh - just wondering where you’re opening the PDF from?

Is it locally stored, or are you using Cloud storage like the MediaDB?

Hi @domhnallohanlon. They are all stored locally. And I am well under the max limit for size and total mb size for the app too.

Thanks for the clarification @steveh - I will investigate further with iOS and see if I can find anything for you.

Is this a major part of the app that you are trying to publish?

Yes it is @domhnallohanlon.

hi @domhnallohanlon, have you been able to find anything further on this issue? I have not actioned another build as yet, hoping you may have some news? I look forward to your reply. Regards

Hi @domhnallohanlon. I just tried another build for iPhone and still have the same issue on the new build with the PDF viewer function that when you click on the PDF, i get a white screen and then have to close the app as you can’t go back. It happens in Test Flight and on a build emailed directly to my phone via the thunkable page.

1 potential workaround that looks nice, is to host your PDF in cloudinary and link to the PDF in the webviewer


Thanks @jared. Appreciate the input. I will look into that now. :+1:


If that works, please report back here and let us know! I’m always happy to help find solutions to our problems!

@jared Looks pretty good to me. I hooked myself up with a Cloudinary account and swapped out the PDF reader for the webviewer as you suggested, and made a new build. Everything is working locally on that build, which it was not previously. Thanks for your input and the suggested work around! :+1: Problem solved.


I had the same problem at my mac. I just needed to convert pdf. https://pdf.movavi.com/pdf-editor-mac/ - the easiest way to solve this problem.