Pdf file doesnt open

Hello, i had posted a PDF file on Cloudinary and connected it to thunkable. When I open the screen with this pdf on laptop, its fine. But when I try to open it on my phone, it doesnt load. It shows white screen and 0% sign. Can anyone help please?

Can you share the PDF link?

If you open that link on your phone in a browser (not Thunkable Live), what happens?

here is the link: https://res.cloudinary.com/deactlq40/image/upload/v1711553584/fellowship_of_the_ring_ozeter.pdf
I tried opening it in browser, everything is ok
and here is what the error looks like

What device are you testing it on when it fails to load?

In Thunkable, are you entering the url into the properties of the PDF viewer or are you using blocks to set that? If blocks, share a screenshot of them.

on Android, and Im using the url

I can view the PDF in Thunkable Live on an iPhone 13 Pro so I’m not sure what the cause of your issue is. What happens when you view this project on your Android phone?


Hi, sorry for not answering for a long time, but I’ve tried to open this pdf on several androids, and it doesnt work too. While its opening fine on IOS. I cant understand what the matter is

This looks to be an issue anytime a link is used with Android. If you can add the PDF file as an asset in the project, it’ll work just fine.

I have reported this as a bug and we will work to resolve this.
In the meantime, feel free to reach out for updates. Otherwise, I will reach out here when I have more information to share with you via updates or a solution going live.
Thank you!

1 Like

Ok, but i need to upload several PDFs, so there wouldnt be enough srorage for them in assets…