[Solved] No Option to Set Background Image or Color

Hello all,

I first signed into Thunkable and got my feet wet yesterday. I made an app, and set the background and played around no problem.

Today, I decided to get down to work, and I started working on a new app. The problem though, is that when I load it in, there is no option for my screen to set background image or background color. I have looked at countless tutorials and this option is just always there when the editor loads. But me, I have nothing. Did I toggle something somewhere or what can I go so that I can set my background image? The problem is also there with images. I add an image component, but there is no where for me to input the image source. What am I missing here!?

Hello there Tyler, :wave:

Welcome to Community! :tada:

I think Thunkable X developers did some design changes at Thunkable X Platform…
But, a quick solution for you, go to Advanced Properties > Styling > Background Colour.

Refer below :

temp

Hope it Helps :wink:

tap Styling :wink:

1 Like

I have also create same topic on this…
There is no image function and also some other functions are missing…

Any solution?
Any idea what it is happening?

Hi there,

Please refer to this comment:

Hi there,

This issue has been resolved! Thanks to everyone who alerted us to this behaviour.

1 Like

Hi there,
Here is BlueWhaleYT.I’m very puzzled now.I feel that some of the component setting were disappeared.Especially the image,I don’t have way ( setting ) to put the image now…
The label few options now,that’s let me need to go Advanced Setting to do it then…
At first,I think it was my personal problem of the platform,but when I saw someone had this problem too.What happened of the platform now.?
Now it’s too trouble and messy.

1 Like

Hi there,

Due to a bug, it is not currently possible to set a component’s source media in the Design tab.

Instead we ask users to:

Upload your files:
​

​​

​
And use blocks to set media source:

​​​​

Unfortunately with some components, like the spreadsheet, we can’t use blocks to work around this behaviour.

Hopefully, this will be fixed shortly.

Thanks for your patience!

Hello.
Since yesterday evening (my time +2GMT) there is no more a function to add background as image for buttons. I have tested on many browsers…
Does anyone has the same issue?
Thank you.

1 Like

Yes,i know.But it will captured more area if do this even if it is possible to do it on Design Tab.
Just a question,what route you ( the developer ) are making to change the setting?

Now I see that there are many errors not only this. There is no possibility to ad background equal to what element and also some other functions… URL to WebViewer etc…

Any idea?

:frowning:

1 Like

It is pretty weird.I have already dragged and chose that image,and seems that the option “come back” :joy::joy::joy:Screenshot_2019-07-02_200643

Hi there,

Please refer to this comment:

1 Like

Hi there,

This issue has been resolved! Thanks to everyone who alerted us to this behaviour.

1 Like

Hi there,

This issue has been resolved! Thanks to everyone who alerted us to this behaviour.

Thank you!

1 Like