[Solved] Duplicate does not duplicate all properties

When you use the duplicate functionality on a label the font size was not duplicated. the expectation is that the entire set of properties are duplicated.

There had been some issues with this before with buttons and labels where duplicating them would not copy over certain properties such as background color.

I just duplicated a label in a Drag and Drop (DnD) project and it kept the font size.

Are you using DnD or StP (Snap to Place)? Can you share a project where this is happening? Or a screencast of it happening?

Hi and thanks for looking into this: using snap to place I had a column with 2 labels, I set the font size on the first 2 to 24 then used the duplicate to create 2 more labels in side the same column, both of these had the default font size of 18.

I set a bunch of properties for a label in StP and then duplicated the label. Everything looks the same in the duplicate:


And here’s the same thing but with a column containing two labels after I duplicated the column:


Can you post a link to your project?

So sorry,
I repeated what you did and it worked just fine, I also retried a duplicate operation in the exact same spot, and it works just fine. Once again so sorry for wasting your time.

1 Like