[SOLVED] Canvas - Stage - Sprite to display an image and get x and y plus draw a dot

Hi !!
I have been trying for day to create a screen where i display an image of the Human Body. I need to touch anywhere on the image and get x and y and draw a red dot.

I have been able to accomplish both but not at the same time, meaning i draw the dots but get no coordinates; or the other way around.

Desperately in need of Help !!



Hi @Carlos_Bieberach, we are happy to help here. Can you show what blocks you are using to attempt to get the coordinates and draw the dot?

Thank you!

Thank you for your response.

I did a combination of both meaning, dots show on sprite when i touch and coordinates are gathered from canvas - on touch.

Making the sprite 50% transparent allows me to have both all dots and x/y value.

I dont know if this is the correct/best way but it works perfectly.


Hello again Matt,
Something weird happened. For the last 4 days i have been trying to understand what is going on.

Short version:
My only 2 buttons above my canvas stopped working. I went 2 versions back and they work fine. I took photos of these 2 simple pages (old and new) and all is identical.

One button clears the canvas the other invokes my Rest API call to POST information about the dots’s coordinates i have created by touch. These 2 buttons worked fine since i created them 2-3 weeks ago.

On Saturday I added “save canvas as an image” block and I think that’s when my 2 buttons on that screen stopped working.

You click on the buttons and you see the reaction but no execution.

I even removed the 2 blocks inside my Clear sceen button and added an alert just to show the word “hello” and no alert pop up yet the button shows the effect of being pressed. They simple do not execute the blocks in them.

Any ideas?

How can i privately share my project with you?


@Carlos_Bieberach There was a bug from last week caused by having a function with an output (return) will cause all other components on the page to also not function.

Screenshot 2024-04-11 at 10.21.41 AM

Can you add a new block (e.g. a new click event) into the screen so that the code can recompile for the updated code after the bug fix? This should solve the issue and you should be able to have clicks working again.

Thank you Matt,
Yesterday I added another button just with an alert that reads “Hello”. It doesn’t get invoke when I click on the new button. You can see the “click-effect” on the button when you click on it, but no action is executed.


just added a new button with just a text alert.

removed the “return” block from my http POST

same results.

You see the new button getting clicked but it does not invoke the alert “hello”

Good morning Matt,
All my pages have functions that return a result and they work fine. I only have this problem with the page where i use Canvas. Yesterday I remove the block that has the http POST and returns a response but same issue, the 2 buttons click but do not execute.

Any updates from your side ? Customer is getting worried. I don’t what else to tell him.


Can any other Staff Member answer ? I don’t know what happened to Matt.

Where do i open a ticket ?

I pay a membership, is there a Customer Service or Support Department ?

Thank you,


Hello @Carlos_Bieberach
Matt is out of the office until next week.
Could you please test it on Web Preview?
image (1)

We were able to replicate the issue on mobile and have flagged it to our engineering team.
We’re committed to finding a resolution quickly, and we will keep you updated as soon as there is any progress.

If you’re on our Pro plan or above, you can always get expedited support by clicking on the Help icon and selecting “Contact Support” in the top right Menu bar in your Project Page.
Screenshot 2023-07-06 at 10.54.50 AM

Thank you ioannis for your response.

Will test on Web Preview in a few mins.

Im on the Pro Plan and my Help dropdown only shows: Documentation, Community and Video Tutorials.

Thanks again,


Hello @Carlos_Bieberach
Thanks for sharing more information.
On StP the support is here:

Hello ioannis,
Web Preview worked.

Then i created a new Form and instead of a Blank Form I selected “Copy from My Screens” because in order to avoid my Apps’s Registration Form and a bunch of security, I added this screen with the Canvas to “My Screens”, tested it with Web Preview and worked, added it back to my App and it shows as Pain1 since i already have a Pain screen. I click, i see my dots. I hit Clear button which invokes block “Clear drwaings on Canvas 4” and it clears the canvas.

I tried 4 - 5 dots created with the touch of mi finger and was able to eras all.

Switched from Design to Blocks and Clear button stops working. I can close and open app again with same results, the button will never work again until i erase the Form and download it again from “My Screens”.


Hello ioannis. Any ideas what could be wrong.

I dont know whatelse to tell my customer.


Hello @Carlos_Bieberach
Thank you again for your patience. I would like to let you know that we have now officially released a fix for this bug.

Please keep in mind that you may need to do a hard refresh of your browser for the changes to take effect in your project. If this issue is present on the Thunkable Live app, you will want to update that through the App Store and/or Google Play Store before any changes will occur. If your downloaded or published app is affected by this bug, you will need to re-download or re-publish your app for these changes to take effect.

Thank you. Will test right now.


1 Like

Hello ioannis,
It is working now.

Thank you !!


1 Like