[Solved] Can I use a variable to store a Data Viewer Row ID?

Hi,

https://x.thunkable.com/copy/17f4d8be352460ca73aca03b8aaccb94

Please take a look at the project above. In screen 2, why the “get value from” can’t fetch correct data from the table1 by using a variable in row id slot?
It works when assigning row id to a specific number, e.g. “1”.
Am I assigning the variable in the wrong way?

Thanks

it probably should not work that way. rowID is reserved for a unique number that is produced only when you save a value or have a prepopulated table. the rowID is not the row number. this could be why you are having issues.

perhaps this was changed or is not being named correctly in the blocks? perhaps a bug?

the call block is not accepting the created rowID. this is strange. can you report this on github?

Hi @jared,

it seems this is a new bug. Because two days ago(I believe there was an update yesterday?!), it was working properly. By properly, I mean I can put the rowID to a variable, and use it to call a specific row from the table and display it correctly.

I think I could report to Github.

I like using row numbers. The changes just need to be consistent! Github will be the place. If you don’t hear back in a couple days, try messaging an admin directly to prompt them to look at your ticket on GitHub.

I imagine they’ll see it right away though!

Hi @jared,

Would you mind give me an example of using row numbers? I am afraid I am going to misunderstand what you mean by that.
I am sorry if I ask too much, but I am close to the deadline of the project, and I am 50% complete. However, I can’t proceed if I can’t load data from the table.

This is a bug, it’ll be fixed in the next release (need to wait until daytime in SF). Sorry for the inconvenience.

3 Likes

Hi @paulmw,

Do you mean it will be fixed in the next business day during daytime in SF? or a couple of days later?

Thanks for clarified!

I can’t guarantee when releases will get out. I just fixed it internally, it needs to be reviewed by another developer and deployed.

The change involves a change to our mobile code, so when it gets released may depend on the app review process in the iOS and Google Play store. We’ll try to deploy it as soon as possible.

2 Likes

Thank you, I appreciate that!

Hi. Is this solved?
i also almost done my project but only problem is about data viewer (and row id)

—the details of my case—

condition: i have database which will be written by users. and i want to use dataviewer to show the db. (user can click to see the detail of each item, or can change/delete if he/she is the writer)

the feature i need is ‘sorting’ and ‘filtering’ (to spreadsheet)
(specifically,

  1. sorting table : recent scheduled ones in first, and future ones in last (about schedule they wrote. not the time data saved)
  2. make several filtered clone sheet : so that user can view each specific type of data)

as you guys know, when i use ‘sort’ or ‘filter’ formula(/function) in google sheet, it needs original sheet.
so i may use datasource as original sheet, and make new sheet(s) using formula to project to dataviewer(s).
in that case, if user pick an item, the app needs to follow original row so that modify or delete the values. so i need to record each row id (of original data).

BUT, unlike what I expected, if original data deleted, then somehow row id doesn’t work as before. the value of row id changed.
and similarly, if i created new row to original sheet and if that row will be sorted in the middle of viewer sheet, then it doesn’t work what i expected too.
oh, and if i reboot the app, the row id comes back!! to what i expected.

for my understanding now, row id follows an order not the value.
sorry for not uploading screenshot.
but please let me know when the bug fixed. and what is the characteristic of row id, and what i have to do.

thank you for reading this. and always pulling for thunkable team.

Hi @saramdl.gaunde021

The bug describes above is fixed.
https://x.thunkable.com/copy/4477bc14c0b0f13ca7ff7ae89e7a22ae
This test example can verified this.
And you must update Thunkable Live test app on your phone to the newest if you are using the phone to do live testing.
I am not sure if you are running into issues because of this bug.

thanks. im not sure either.