Shareable Link not Working

Hello! My team and I created an app, which is supposed to be submitted by tomorrow (Monday, April 19 at 7:30 PM EST) for an app challenge hosted by Technovation. However, the shareable link isn’t being generated, so we can’t submit our app. We would be extremely grateful if anyone could help us!

What happens when you try to create a shareable link?

When we try to create a shareable link by clicking “generate link”, it says share link generation error and there is no link that we can copy. Any help would be greatly appreciated, thank you!

Hmm. I just tried to generate a link from a project I have and it worked. You might try clearing your browser cache to see if that helps.

Hello, I just tried clearing my browser cache but when I went back to the Thunkable app project, I’m still not able to generate a shareable url. As per the Thunkable discussions, it seems that many Technovation teams have faced this issue and it is something that needs to be manually changed by a Thunkable leader or lead.

Hi there,

Can you share a project link with us? You can send it to me in a private message here or on Intercom.
A project link is the link from your browser that begins with


Hi there,

Thanks for sharing the link to your project with me. I’ll share my reply here in case anyone else is interested:

"The error message I see says “Problem communicating with server. HTTP status: 500, server message:”

This usually means there is an issue with assets in the project. I tried fixing the assets on my end, but the message persists. I will follow up with the team about this.

Is it possible to share a project page link for your project with the intended recipient, or does it have to be a share link? A project page link would still allow the recipient to preview the app online and test it with the Thunkable Live app."

For anyone else affected by this behavior, please try sharing your project link with a team member and we might be able to resolve this message by fixing the project assets.

1 Like

Do you mean that this has come up in the past (which it has, and is usually fixed by an asset fix on our end), or are many people affected by this behavior right now?

Unfortunately, we’re only allowed to submit a share link.

We have not tried generating a shareable URL in the past so this is an issue that we are dealing with right now. Thank you for your help!