Set label's text not working for me!

Today, when I was working on my submission for WDC 13, I realized that the label’s text wasn’t getting changed at all. In fact, I wasn’t able to set the text of any label. I had some in list get blocks for my label, so I decided to test it by using

When screen1 opens,
Set label1’s text to Hello World.

That didn’t work. Are any other people facing this issue?

2 Likes

ya for me too:
2 labels are not visible
same with date input component

2 Likes

My labels are visible. I’m saying that my text is not appearing in my visible labels.

1 Like

ok

did u get it now i tried deleting the component and adding it again to my screen but…

1 Like

No, I deleted it and added it again, but there’s still no text coming. It works when I add it from within the designer tab, though.

1 Like

did it come now?

No, it didn’t!

ok

Working now. I made the app again. I have no idea what happened.

2 Likes

the whole app or only specific screen?

The whole app.

This post was flagged by the community and is temporarily hidden.

Another problem: none of my code is getting saved. initially, I have 264 blocks, and then I reloaded, to find that there were now 146 blocks!

I have lost all my work due to this… has anyone else had problems saving work today?

1 Like

Yes, I had the same problem last night with my WDC project. I worked for about half an hour and never saw any error messages but my new content wasn’t appearing during preview so I hard-refreshed the tab and then re-opened the project and saw that none of my changes had been saved.

3 Likes

Yeah, I had to make the app all over again. @domhnallohanlon is this a bug?

1 Like

That happens to me sometimes but I find that when I am done, I leave it open in the background for 5-10 minutes to make sure it has time to save everything.

1 Like

Not that I know of… but will keep an eye on this.

Wondering if this was an issue with the screen opens block or the set label text block?

2 Likes

It’s the set label block. Other events were working within the screen opens.

None of my work is getting saved! I’m done with my app, but none of my changes are getting reflected, so it’s like I haven’t done a thing. I’m extremely scared to reload because I’m sure I’ll lose all my work again. And, considering my app has 467 blocks, and I’ve remade it thrice already(due to the saving issue), I’m not going to be able to remake it once more. It’s worth 4-and-a-half hours of work. Please, please fix this as soon as possible. I won’t be able to close my tabs or shut down my computer until you do.

1 Like