Scroll in the Column doesn't work

Scroll in the Column doesn’t work! It works (badly) in Live Test but does not work on Thunkable Live.
This is a test:

Has anyone noticed this problem?

Hi @biagio.prisco, thanks for bringing this up again. I have re-flagged the appropriate parties to take a look at what might be going on here. I am hoping we can get some clarity for you here soon.

Appreciate your patience!

Hi @conroy33, thank you for your reply.
The problem I posted is similar to the one I posted previously but it is not the same!
The example I just posted was working until two days ago. Then, all of a sudden, it has not worked since yesterday.
I did a lot of testing these days and had been able to figure out where Thunkable was malfunctioning. Now there are more problems…
I will summarize.
First problem: in a Column object I insert several Row objects (with height set to %, e.g.: 15%) each with a button and a label. I set the Column to Scroll. With Live Test and Preview it works but with Thunkable Live or by downloading the app it does not work.
While waiting for you to solve the problem I have, temporarily, solved it another way: I set the height of the Row objects to absolute value (ex: 150 px). This way it worked. Until two days ago. Now, without having done any intervention, it no longer works. I did this simple test
and it doesn’t work.
All tests were done on Smartphone and Android tablet.
Now I am stopped and in a few days I am supposed to submit an application.
What should I do? It has been several weeks since I highlighted the problem.
If you need to know any more information to do your testing please ask me.
I have done a lot of testing…
Thank you

Hi @conroy33,
Have you solved the problem? I’m supposed to submit the project in a few days and without the scroll, the start menu doesn’t work…

@biagio.prisco Thanks for checking in. We appreciate your patience in this issue. Unfortunately, I don’t see this one being solved any time soon. There are a number of factors at play but our engineering team will have to be all-hands-on-deck for some work involving updating our infrastructure for the foreseeable future. These updates are required to keep our platform functioning and our Live Apps on the Play and App Stores.

One thing I can point out for this specific issue, it is only present for Snap To Place projects. You can very easily convert this project to a Drag and Drop project by clicking on the “Convert to Drag and Drop” menu icon at the top of your screen

The scrolling behavior as you are wanting it for your app icons is working on Drag and Drop projects, I just tested it myself.

Please feel free to reach out to me via DM if you have any more questions about the Convert to Drag and Drop process. I think you will find your app functioning really well in that format and you’ll be able to publish in no time at all!

Hi @conroy33, I want to try to switch to Drag and Drop (although I think it’s bad that an object with scroll doesn’t work…).
I don’t see any icon to convert the project though.
See the attached image


I tried creating a new project with Drag and Drop.
However, I don’t see the Web_Api component.
How to do it?

@biagio.prisco I added you into our beta access–you should have the ability to convert the snap to place project to drag and drop now.

Web APIs are in the advanced drawer in our drag and drop projects. Here are our docs for Web API:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.