Receive data with HM-10 BLE module

I am currently doing a simple test to receive data from HM-10.
However, it can not be received well and the characters of the received data will be garbled.
The RN4020 BLE module can receive data without garbled characters.
Please help me!:rofl:

Hi. Share you project…
I Will help you

Thank you very much!
I can transmit without any problems in the tests I’ve done until now.
I can not receive from the HM-10 BLE module.
I tested it on Thunkable Classic to try it, but I was able to receive it.
In Thunkable X I do not know how to do it.

Do you consistently get the same “garbled” response?

Because it may not be garbled, it may simply be differently interpreted, by regrouping data to form multi-byte unicode characters.
Try sending the NUMBER 12345 instead of a “12345” text string.

When transmitting from “Thunkable X” to “HM-10”, text strings can be received with “HM-10”.
When sending from “HM-10” to “Thunkable X” I always receive the same garbled reply.
I tried to transmit numbers from “HM-10” instead of text strings, but the result did not change.
Thank you for the advice.


Another thing perhaps worth checking.
I notice that your receiving block is in a “Timer” block. What is controlling the firing of that timer?
Is it firing continuously? And what is the millisecond interval setting?

I am wondering if you are not receiving again AFTER the original, even when there is nothing transmitted anymore.

The timer has an interval of 500 ms.
I need to constantly monitor the incoming data from “HM-10”.
I also tried to receive when I pressed the button I thought the timer was a problem, but it was the same.

If you do the same thing with Microchip RN4020, I can receive the expected string normally.
It may be a problem specific to HM-10.
However, there is a question that “Thunkable Classic” can receive but “Thunkable X” can not receive.
I will investigate further.
Thank you!

hi, i have the same issue too. i cannot receive data from BLE but can transmit data to other device thru BLE. herebelow pls find my project link, thank you.

Did someone find a solution?

I have the same problem with the HM10 module. It sends ok, but doesn’t receive. I have tried a COUPLE of things, but still doesn’t work. Thunkable X app doesn’t receive at all.

Here’s a link to my project:

hello, same problem here

BLE on x-app won’t receive at all

Similar problem for me.
I get this error in output for the BLE component:

can’t read the characteristic provided

I connect via device name then use Characteristic UUID to receive info via Call Receive. The info is float 4 byte: like 25.000000. When I try to set data my app receives to a label I get undefined.
@domhnallohanlon Any ideas what is wrong?

My problem is related to Thunkable: it converts a float or an integer it receives to a string. In my case sending integer 50 is received as string “2” at Thunkable app.

@takayoshi.koseki i am doing the same thing with your project that use a rn4020 (with arduino uno r3) to send data to thunkable x app. Can you show me your arduino code , i really need it. Special thank in advance.

Another question: can you show me how to get the uuid of rn4020. I used the lightblue app but it didnt work. Please help me.
Thank you 3000 :slight_smile:

any update on this?
I have same issue with BGX13 module
I can send but not receive .
thank you.

Nah, they don’t care about this problem.

Same problem here. But I get this garbled data even if the module is not sending anything.

Any update on this?

Same Problem with nRF52832. I receive garbled data when using receive string but when I change it to receive byte array I get the below error:

n is not a function. (In ‘n(void 0,I.t0.message)’,'n’in undefined

my data is in hex format so I should use byte array but I don’t know how to fix the error.