OpenAI ChatGPT API KEY not working

Hi , after chatGPT was integrated in Thunkable I followed the Thunkable documentation and it was working in My Thunkable app. But when my student tried it the same way , it was not working for her, the app gives “undefined” as the response , Anyone facing the same problem or can help why it may be occuring? The codes and process of applying API key is same.

it’s still working - show us what blocks you’ve put together (cross out the api-key)

2 Likes

Thanks @manyone for your time and reply. Here are the design and blocks images of my app



Sorry for a bit darker images, hope you can see the details here. TIA

did you open it as a d&d project?
read this:

you do need to enter your api-key in the settings section of the openai services (beta) panel.

1 Like

Thank you @manyone . Yes for sure I am using D&D as Open AI is not available on classic mode. I have put the API key in the set API key block as shown in the code blocks, sending the clear screenshots again. Can you please elaborate where exactly to put the API key in Thunkable code


then there’s only one reason i know why it’s not working - before you got an apikey, you must have registered your name and added a credit card. they gave a max $18 credit during the trial period - you may have used it all up. and your apikey has been disabled. youlll have to login to openai and put it some more money in to your account

did you read the link i provided? it describes how to enter the apicode (not through the set block) by a special settings adjusment. please read the link.

Thanks @manyone .Yes I have put it now, earlier I missed doing that, but still its not working.

Also, I have created this account in OPENAI just a day ago and using the API key hardly 2-3 times to test its working and I have not put any credit card information. Is it needed?

@cseducator_mindchamp
Could you please share more information about your issue?
How did you test it?
What text did you add as a prompt?

1 Like

Hi @ioannis Thanks for your reply. I am using simple prompts like what is python, what is thunkable etc. I am getting undefined as the response. I am trying to connect to OpenAi support also but they have not responded till now. I am copy pasting the issue I sent to them here as well, May be you can help me with it . (Disclaimer :Since I am handling the curriculum dept so I need to figure it out for my team.)

" I signed up for OpenAI and used it’s API key in one of my Thunkable projects with email id no 1. On March 13, I created one more account in OpenAI for my colleague in my device with email id no 2, to use API key for another Thunkable project . This new account API keys are not working for their Thunkable projects but my old ones are still working in my projects. I didn’t put any credit card information in either of them, also I didn’t pay anything. Can you please help why the new account API is not working… They both use different email id as user id, only the device was same, the phone number was also different. "

I have tried to open the Thunkable project in other device also. There also its not working.

Could you please check API usage OpenAI API
This way we will see if the API is called and when it expires.

You can also test your account on Playground

1 Like

Thank you @ioannis . These are my screenshots, I somehow feel that they have made it paid for the new accounts.


I found this in the FAQ ChatGPT API FAQ | OpenAI Help Center
The first question has something for free trial users but further below that it says ChatGPT API is not free.

It seems that you do not have any credits on your account.
In order to use the OpenAI feature on Thunkable you need to add a valid API key.
For more accurate info in ChatGPT it is better to wait for their customer support answer.

2 Likes

Well they have not reverted yet, sent a reminder also.

Thank you so much for the help and your time here at Thunkable Community.

1 Like