My Android app NOT WORK!

Hello, Please help me check my app, and why it’s not working when installed from CH Play, all information is below:

  1. This is what happens when I open my app:
    IMG_1233.MOV - Google Drive
  2. This is my android phone system:
  3. This is my project link:
  4. This is my app link on CH play:
    If you need any information please tell me!

Hello @steven_dau
Could you please try this project?

In order to upload this app into the play store you will need to set up again the API keys, your App (Bundle) ID, version code & name, and import your Android Keystore

Then, download the AAB file, and try to upload it to the play store.

Let me know if it worked!

1 Like

Hi @ioannis ,
It took me a long time to update my app with your link, and I published my app with your link on the Google store, but it’s still not working! :frowning:

Hello @steven_dau
I am sorry to hear that it didn’t work for you.
I understand that it takes time but is the only method I have seen helping other users solve similar issues.
Could you please try this app?

Nothing happened, and I can’t open my app :frowning: , something was wrong in your source code for the android app, I think so and I don’t know how long will it take, I feel disappointed!

I’m sorry to hear you feel that way. I realize how upsetting this must be.
Let’s try and find together a solution.
Did you try to use the second copy project I sent you? I tested it and it works.
Could you please try to generate a new AAB file and upload it to Play Store using the project I have sent you? Are you sure that all your API keys are valid?


  1. I used the second project which you sent me to public it on the Google store
  2. What do you mean about API key? Airtable API or what?
  3. Thunkable apps work well with IOS and it WORKS for android if I download it, but It doesn’t WORK when I download it from the Google store!
  4. I will generate and upload again.

Thank you for sharing more information.
Maybe the issue is with Airtable or with AdMob(interstitial or Reward).
Having invalid keys in one of these can cause issues on Android.
Could you please try to remove AdMob for example and check if it works?

I removed Admob in the latest version which you sent me, but it didn’t work too.
I think the problem may be in Airtable, Let me try to remove Airtable. But why iOS apps are still working well :frowning:

I tried to find another way to design my app, but my app is an Audio app, and I can’t upload mp3 to Webflow, Google sheets, or own table! So it means I don’t know how to I design my app :(( without Airtable!