Login with Google - Thunkable/AppInventor



No, sorry :sweat:
I’m not good at making extensions :sweat_smile:

Maube you could ask other person for it


Do you know if I can use the activity starter for the google login scope?


I dont think so, imma look for some OAuth intents if there are.


so I tried this by pasting the URL for the web viewer in the chrome browser using activity starter and I got my Auth code which works but I don’t want to copy the Auth code manually every time. Any ideas on how we can get the chrome or browser to pass the page title back into the app inventor app automatically.


I’m trying with activity starter. It’s good but i’m not able to pass date and time.


Check out WebViewer Dialog extension: Releasing the "Web Viewer Dialog" extension! this extension supports OAuth (Login with Google).


With the latest additions to the extension, it’s possible to complete the authentication process and have access to the Google Calendar. All due to the great work done by Ben @ILoveThunkable; you’re a myth!!!


This method is alive again :blush:

Just use it with the normal parameters and add the EWV extension to the project and add the block to support OAuth in the WebViewer


Hi! For start your job is superb and i thank you for this extension. Is it possible to have a tutorial how to use it?
thanx again


Now I’m working full time on #chatable, but when I finish I will update this method with the new version :wink:


I & @Sivagiri_Visakan created this extension :wink:


Can you update apk file


Did you read what he said.




#Version 2 ready!


WebViewerDialog right? :wink:


WebViewerDialog plus ExtendedWebViewer


I used @Barreeeiroo tutorial and i got an odd problem.
Everything works fine IF i use the tutorial webserver https://scripts.thunkable.ga/google/oauth/

But, if i use my webserver, my logic block on WebViewerDialog1.CurrentPageTittle doesn’t work the first time.
I need to push my android back button (from my device) and click the “btnLogin” again, then it will show “Logged In” status.
If i didn’t push back button on my device, it stuck in the WebViewerDialog1.Create state.
It seems that i need to push “btnLogin” twice in order to get “Logged In” result.

I also tried my webserver with Chrome browser on my computer and with my device and it looks ok, i get returned with “Logged in” as a title immediately.

Did i miss something?
Can anyone help?
Thank you in advance.


Doesn’t Work


nominated for the most helpful comment of the year
/sarcasm off