[In Progress] Text input box does not accept user input

Text input box does not accept user input.

For the following items, iPhone 9 is OK but iPhone7 is NG.

  • Can’t enter text
  • Can’t scroll the screen
  • There is no response such as click, submit, etc.

Would anyone please tell me a solution for this case?

1 Like

Can you share blocks or the project?

1 Like

Thank you for your reply.

The link for this project is below.
https://x.thunkable.com/copy/a7ab300a141db7e0e113e9fc49836095

The text input box of the following items cannot be input.

  • Sales
  • Distance
  • Number

Thanks @Eiji,

The text inputs seem to be working fine for me? Can you share a screenshot from the iPhone 7 please?

I opened it on my iPhone 7 and it was able to work. And I can’t see anything in the blocks that would be causing this problem

domhnallohanlon, huntermclarkn: Thank you for checking the app.

My device works like an attached video.


Device info-Text input box

The same app did not have this problem around February of this year.

Is this the same issue as the attached image?!

https:::community.thunkable.com:t:solved-text-input-box-doesnt-take-in-user-input:569332:2

It seems like the latest version of the TextInput might have a few bugs @Eiji.

Is that screenshot from a PM or can you post a link to the post too?

screenshot link :

Thanks @Eiji,

That certainly sounds similar. Does the same apply to you? Are your Text Inputs inside rows/cols ?

Does moving them solve the issue?

Q1. Are your Text Inputs inside rows/cols ?
A1. Yes

Q2. Does moving them solve the issue?
A2. The text box “Remarks” can be entered, but “Sales, Distance, Number” is an input NG.

The link for this project is below.
https://x.thunkable.com/copy/a7ab300a141db7e0e113e9fc49836095

Thanks @Eiji - the video is set to private.

I think if you change it to “unlisted” we’ll be able to see it.

I’m sorry.
The video has been released.

Hey @Eiji - I wonder if this is an Thunkable Live issue? Do you know what version you’re using?

I’m on the latest version and my test app and your app worked fine for me:

and:

Thunkable Live is the latest version.
Downloading and publishing the app is the same issue.

Hey @Eiji

This is really strange, I tried on iOS too and I just can’t seem to replicate the behaviour you are seeing

What version if iOS are you using? Also, any idea why our keyboards look different?

Hi. There were new features about text input in last update. Like can make some events when text input click / change / unfocuss / submit. And it is really cool and i appreciated team.

But here comes new problem.
User can’t click text input while keyboard is visible for another text input.
Someone may think user should dismiss keyboard by themselves by submiting it or press button for close. but mostly they do what they want. And sometimes they cant submit if there wasnt any other button for it. (Like iOS num pad)

This is my app for signin (not using FB auth fyi)
And user cannot move to password input nevertheless they finished typed their id. The only solution i know is pressing return key to escape the first text input. And then the user can move to the next one.

And i think this is not good for most users. Thanks.

Thanks for highlighting this @saramdl.gaunde021 - if you change the return key type in the advanced properties, does that make any difference?

1 Like

thanks for reply. return key was just an example for my situation. (i did after you said thanks) but it is not a solution i think.

and here’s another thing. can’t click another “button” too when clicked text input. i don’t know it is because of button’s location or it is in the same column or something?