Text Input Doesn't Work :(

Hi! I really need help… BADLY. ;(

My text input component just won’t work. When I live-test it on my computer, all the inputs’ hints are visible, and you can type in it.


But when I live-test it on my android phone, the top 2 text inputs don’t show their hints, and clicking on them does nothing. I am in despair!!! Can someone please help???

Thank you everyone in advance :slight_smile:

Best regards,
Anika

1 Like

You will need to share a copy to your project so that someone can look into it.

1 Like

Thank you for the speedy reply! Here it is:
https://x.thunkable.com/copy/9ea6545ead832f2c9620f5c18a7bd0cb
Note: The input issue only occurs when live-testing on a phone. I tried both my Android and iOS phones, and they both had the same issue. Thunkable Live is installed with its latest updated version, but MAYBE it’s the problem. I don’t really know…

1 Like

I see what you mean about the text inputs not working on an iPhone. But I have not been able to duplicate the issue myself when adding a new Text Input. I’ve checked every property of the Text Input and I don’t see any difference from yours. Very strange.

Maybe try adding a new text input?

2 Likes

I faced the same issue after making an update to my app recently (update was nothing to do with the text inputs).
after a lot of messing I solved it by going into the advanced tab of the text input and changing editable to false and then back to true.

1 Like

Thank you for responding! The problem has been solved now :slight_smile:

Thank you for your response!! It worked for me too!! I can’t show my gratitude, this problem really bugged me for a while. Once again, thank you!

1 Like