Image url from data source not displaying

i am trying to display images for recipes using local data source. All other information pulls in to my recipe page except the image. I have tried google drive and cloudinary. I have checked url and it is set to public. I have no clue why they will not show. Attached or shots of data source and screens the image are not showing on. Many Thanks.
Screenshot 2023-07-04 at 06.32.28
Screenshot 2023-07-04 at 06.33.10

Can you post the two image links as text? That way we don’t have to type them in to test them.

Also, post a screenshot of the properties and panel (the right side of the screen) from the Design tab of your project.

Thanks for your reply. Here are the url in text.

I do want to add lots more images to the database but first want to make sure they actually work.

https: //
https: //

I can confirm that I can view those images in a browser (I realize you already said they were public). And sorry, I forgot to say that you’ll need to click on the Data Viewer List (DVL) first and then take a screenshot of the properties panel.

Are you able to display those two images in Image components in your project (as a test)?

Sorry i am not understanding. Those images might be able to be viewed but they do not appear on my app screen, or when i test. I followed a video and all other data is transferred into fields, so when they click on recipe ingredients is shown on another screen, but the images do not appear so i can see them next to the recipes as shown in the screen shots. Also, i can see the DVL but i dont know what you mean to click on it and then screenshot? I don’t know what you want me to show you. Sorry for not understanding and appreciate your help.

Are you able to share the project by posting a link to it here?

@info65 @tatiang Just want to confirm one thing here. When using a DVL or DVG, the URL to populate any image must end with the file extension (eg

Some background, the image either the DVL or DVG is an image component and so it has to follow the above rule to render the image.

1 Like

Did you fix the image extensions?

Hello @info65, the problem is in your image link, i am talking about the screen 4, but in this way you can fix all images
the first link of google drive that you are using is not public or i think it can be any bug, but when i just opened that drive image in new tab, the google photos link that open, i just used that.
And the second link of Cloudinary is also wrong, please click on the copy link of image of cloudinary dashboard to get a proper image link.

I suggest you to please only use cloudinary for your app and for all images.


The way to get cloudinary image correct link:
Just hover over the image of the cloudinary image and you will see two options - copy url, more btn, You have to just click on copy URL, and then use it, do it for all images.
EXAMPLE - cloudinary image format -

@info65, if this solved your problem, then please reply success message or mark this issue as solved.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.