[SOLVED] Image not displaying

My App is not displaying images from Spreadsheet,the blocks were working on my other apps,but not working here
Please thunkers

Hello @versatile
Could you please check the image type(PNG, JPG, GIF, SVG, etc)?

1 Like

The images type varies from PNG to jpg

1 Like

@versatile how do you save the images on Google Sheets?
Do you use URLs?

Yes ,it was a url from Cloudinary Media

@ioannis I am having the exact same problem . However I have noticed that if you set the image to the url from the design screen, the image from cloudinary will appear in your app. It seems to be a problem setting the image from a variable .

1 Like

Hello @j.oraziog296 welcome to the community.
Thank you for sharing more information.
I created this project in order to replicate the issue but it works for me.
Could you please check?
How did you test the app?
Android, iOS, or web?

1 Like

@ioannis your code works, and I must have a problem with my list. I am pulling the airtable rows into a list. I have the url set as an image and text set to a label. Originally I could see the text and not the image, now I can’t see either.

In my case the link generated by the cloudinary are saved on to the Airtable spreadsheet,and I set a timer to display theses images on the at a given one after the other with the “Timer” feature continuously whenever the screen is opened.
It worked perfectly on Stp but not on DND

here are my blocks from an earlier version… I’ve hardcoded a search string for now. the url is displaying as text as expected in the list viewer. but the image is not appearing.`

1 Like

so what could be done

any updates?

What is the image url? How are you trying to display it? Does it display correctly when assigned to an Image component?

Hi @tatiang . the image url is (https://res.cloudinary.com/dvsqe85pw/image/upload/v1691450670/ndyq3gvtv84e1hbe1mv9.png)
(it’s just a test image during the build stages) . I have a similar arragement to @versatile - the cloudinary image url is stored in airtable, then queried through a list. Then finally the URL selected from the list is set to an image component (via a variable).

If you set the Image component’s url to that url manually, does it show up?

If so, then you aren’t getting that url correctly from Airtable. If it doesn’t show up, then there is an image formatting problem.

Actually, looking at your blocks, you’re trying to assign a list variable to an image. You can’t do that. An image url has to be a text string.

1 Like

thanks for your input @tatiang - back to the drawing board. If you can give me some insight on how I can solve this it would be appreciated. My airtable only has 2 columns and I just want to query a column and then return the photo url with a corresponding match. Unfortunately thunkable does not support SQL queries, which I am quite comfortable with, and I am not accustomed to quering databases in the manner demonstrated by thunkable documentation.
As I stated in an earlier post when I was testing, the url was populating the list view or label, so I could see the url I wanted to view the image of

It’s hard to troubleshoot this because you haven’t answered the questions I asked so I’m not sure what to recommend now.

To display an image, you would need to:

  1. Get the url from Airtable
  2. Assign the retrieved url to an Image component’s picture

Is #1 working? It sounds like it is if you can display it in a label.

Is #2 working? If not, does it work to manually paste the same url into an Image component’s picture in the Design tab and view the image?

Yes , #1 is working.
But #2 is not. And yes - I previously tried setting the image URL to the image component directly on the design page and that is working,.

Then the url is correct but you’re either retrieving it incorrectly or saving it incorrectly in a variable. I mentioned before that you were trying to store a url as a list. Have you fixed that? If so, post an updated screenshot of your blocks.