How to empty an table entry (cell)?

Hi there,

I’m stuck in some (seemly) simple problem. I use a normal data source table and I want to empty table entry. Not to delete whole row. I was thinking to just make an empty string but not working. I also tried to give null to te table entry but nope not working. Please help!!

problemo

Those blocks should set the UID for the selected row to an empty string (“”). The rec no input value would need to be an integer.

What do the blocks that call your recycle function look like? Have you tried a simple when button clickrecycle set of blocks?

And how do you know it’s not working? How are you checking the value of row # rec no after the recycle function completes?

I expanded the image of blocks a bit. My call to the function has an integer as actual var.

I call the function by a click on that nice GUI button.

On the Gui I have 2 debug lables. The first lable should show up empty when the cell on my table is empty. I tested it with another empty cell as value for that lable. The second lable gives me an counter to check the function ran or not.

I also upload my database.
database


Is your my_devices database a local table or a cloud site such as Google Sheets or Airtable? If the latter, can you see the change in your database from the update value block?

Because my guess is that what’s happening is the value is changing but you’re experiencing the get value block bug. You can read about it here:

I’d recommend using the get row object block instead and getting the property of the object for the column you need (“UID”).

Hi Tatiang,

First of all many thanks for looking in to my problem already.

The entire project is for home automation. I use Arduino’s to switch lights on and off. The App I’m building is to control them. I connect them trough Bluetooth. All is working fine but for version 2 of my app I plan to make a settings screen in witch I can change the devices. For now I can add new devices and change the image on them. All is logged on the DB (table) on my phone. Only thing is to recyle a device. I was thinking about delete entire row, but problem on that solution is I lose the whole row and can’t add a new one if I want.

I use the local table for my DB. I planned to do this for reason I don’t want to rely on internet based content. In early stage of my project (not using bluetooth) I experienced a malfunction on internet provider side, and could not turn off the light. So now I don’t use cloud content at all.

Why can’t you add a new row after you delete one? That’s what the Create Row block is for.

Let me know if my suggestions solve the problem for you.

The delete entire row and add new row seems to work. At first I did not want this because I was thinking that shifting a device in order was something I not desire. Now I implemented it and after testing this method is n’t that messy I first thought.

Here the new function blocks. Stil having many debug text inside, so read between those lines. :slight_smile:

1 Like