Help with cloning

I’m trying to clone a container within a layout (beta feature). The container has labels inside. I’m populating the labels from Firebase values. It’s working great to initially clone the first container and fill it with values.

But if I run the function again with a different Firebase key (Journal/app variable date), it still populates the labels with the initial values. I can change the key (each key has unique values for item, time, and note sub keys) but it still shows only one set of values. It’s not updating as I intended.

The Debug label shows the correct values. For example, if I set app variable date to today’s date, it will show the values from that key in Firebase. And if I change app variable date to yesterday’s day, it will show the values from that key instead. But again, the cloned labels will only have today’s values no matter what I change app variable date to.

Any ideas why this is happening?

Also, is there a way to do this without deleting all but the first container before cloning everything again?

Place your master copy outside of the slave column.

What’s it not working on. Mobile or web preview?

1 Like

Thanks, I’ll try that. It’s not working on iPhone 11 Thunkable Live or browser preview.

Study this Thunkable

i use cloning like crazy in this app without any issues

Encountered such thing by myself, and putting some wait 0.001 block right after all label’s texts set fixed the issue (I guess that they need some break time to refresh display new values :thinking:)

Thanks for the tip but that didn’t seem to help in my project.

1 Like

I appreciate that! Your blocks look like mine so I’m still not sure what the issue is. I duplicated the clone source and it’s still behaving oddly.

if you wanna share your project via dm I can take a look. There should be no issue with cloning in a layout from what I can tell

I’m going to chalk this up to a corrupt layout or container. I checked and double-checked all of the properties and even though it’s getting the correct values from Firebase, it won’t populate the labels correctly.

I started over and created the containers and labels again and it’s working fine. I don’t know what happened but I’ll mark this as solved!