Getting List ofGoogle Sheets RowID doesn't match the number of rows in the sheet

I’m trying to do some searching inside a google sheets to replace a value later on and using the rowID of the google sheets as a pointer. Below, you can see i am getting the list of values from the same google sheets file.
image

As i was troubleshoote, i took note the number of values in the list on the ID vs others.
image

I see that the Time one has 269 while the Rowid has 265 entries… this is really wierding me out. Anyone got any ideas?

1 Like

Can you tell me if you’ve been deleting rows? I Know that that doesn’t work as desired, necessarily. That said deleting rows is going to be updated very soon!

Just wondering if that has maybe something to do with this. If you go to your Google sheet, And you see what wrong number the last entry is on does that match up with the number of row IDs?

1 Like

There has been some deleting rows by hand (on google sheets) and some editing through thunkabl, but i think thunkable basically breaks down after 100 rows in Google sheets. Spent like 6 hours on this trying anything .

1 Like

Once you connect a Google sheet to a Thunkable project, you will then need to re-synch the sheet from the My Data Sources tab in the main Thunkable screen every time you add or delete rows from the sheet manually to keep the values and counts updated in the project.

That is something I observed from my many trials using Google sheet as a Database.

That’s a great piece of advice. I will try that out in the Morning.

I also have been getting this issue when i try to write to this tab and then read out from it. Have you seen this before

1 Like

What about adding a row through thunkable, do you need to resync also?
I tried resyncing, and it didn’t fix it. Very strange. And you can’t copy the google sheets to internal table cause the add row doesn’t work. This is getting pretty strange.

1 Like

This is an API connection problem which could be permissions or just a corrupted connection.

First delete the connection from the My Data Sources tab and then head to a project and reconnect the same Google sheet.

If this step still gives the same GraphQL error then take a copy from the Google sheet file and use the newly copied file connecting it as a Data Source.

If even this failed then you need to go to your Google account and remove Thunkable permission to your data and at this stage you will need the assistance of one of the Thunkable staff to clear the connection credentials from their side and only then you will be able to reconnect again. This step will disconnect all available data sources which you will need to reconnect and you will need to revisit every project that uses any of the data sources (Google sheet or Airtable) and reconnect every block in every screen in every project.


This step solves all such issues I faced but it might be due to the GraphQL error that it doesn’t work for you.


This click has always been handy.

1 Like

Okay, after going through the forums, i saw that someone was not getting the id through rowid, but instead used integer values for the rowid. That makes it easier cause the rowid gets curropt.

1 Like

I am not so sure if you are correct. Because i can change the first row by hand in google sheets and the header reads correctily when i sync. But if i right on the second row by hand in google sheet, i get the GraphQL issue. This seem more of a thunkable internal issue. cause i have a good link, it’s just Thunkable gets messed up in reading the body and coordinating it internally.

1 Like

Hey there

I’m wondering if you experience these issues in Web preview, the companion app, and download apps?

1 Like

i found the issue in the download apps when it didn’t bring in the data. Then i had to troubleshoot through the web preview. I noticed that if there was no data (beyond headers), it was working (but useless). Then when the data was put in there (it was able to put the data in there), reading it gave this error.

1 Like

I honestly think there is something that needs to deep dive into this, cuase it was working at some point and then stopped. I really think it needs a deep dive. Cause resetting the whole asset and calling thunkable makes no sense and will cause the company more time than trying to deep dive and figuring it out.

1 Like

Do you mean you have already tried the first two options I explained. The first step is to do a hard refresh for your browser from the main Thunkable screen and from the project screen and if that did not clear the issue then check these two methods.

  • First solution
    Delete the connection of your Google sheet from the My Data Sources tab


    Go to your project and delete the Data Source connection and then re-connect again. This helps if there is a corrupted connection configuration file.

  • Second Solution
    If the error persist then the next thing you should consider is to make a copy of the Google sheet file in your drive. Now make a new connection to the newly created file. This should solve the problem.

You will only need to ask Thunkable to reset your connection credentials if both the above steps fail.

I did both. Second solution worked for 1 week and then stopped working with the same failure mode.

What i did notice is that the google sheets i was used was someone else that was shared to me with edit rights. So, i just now did second solution again with sheets that i was the author on my google account. Maybe that will help.

Just so you know, i don’t get the error if i delete the data (but keep the headers). Once it’s written in the rows, then it gets this error.

Hey @939sbroadway1a9rm2 :wave:

Just checking in here to see if you are able to resolve your issue? If not, can you share a minimal example demonstrating this issue? I can hook my own sheet up for testing. For the minimal, just the blocks and UI will do for this purpose.

1 Like