GetRowObject block in loop still doesn't work

Hello, I’d like to give an update on @tatiang 's post below. The topic & github repo both are closed so I am creating a new one.

This still doesn’t work - I was wondering why my code wasn’t working and then I found the above topic, turns out it’s a known issue. This doesn’t work - (the table’s fine, row id coming fine)

Is there anyone else experiencing the same? Thanks!

@matt_conroy @ioannis

This is what I had to do to make it work, which is really slowing down my app…

In the meantime this issue is solved, does anyone know of a better workaround? Thanks.

Hello @kartik14

We can understand that it is frustrating and appreciate you taking the time to investigate and provide more information.

We created an example project that uses the “ger row object from” block inside the loop and is working as expected. Thunkable

However, I understand that it may not be working for you as expected.

Could you please share a screenshot of your database showing the structure of the fields?