Firebase Realtime Database not working

Hi Thunkable Community,

For the past 6 days I have tried all the tutorials and followed all the documentation but I am not able to store anything into my firebase database.
I have change the firebase datacenter from an european one to an american one.9
(Firebase Realtime database not working when you choose Europe datacenter)

At the begging I tried to run my connection from my own app, Now I am using for
CoffeeTracker (Realtime DB) project from Darren.

What is nice about this project(from Darren) is that is I didn’t connect with my firebase credentials( API key + databaseURL) the app is using just the default Thunkable Firebase account, then I can run the app.
When I connect using my credentials it does not work.

Any tips for solving this problem?
Thank you for your feedback

1 Like

Are you using the old or new interface?

You’ve worked through the setup directions here, including API key and database url? Realtime DB by Firebase - Thunkable Docs

First thought: do you have your access permissions set up right?

Second thought: if you’re using the older purple blocks, are you displaying the value of the error block, and what does it say?

1 Like

Hi Catsarisky,

Thank you for your feedback, I have followed the setup directions and set the access permissions correctly.
This is how the code looks like. As mentioned before, if I don’t enter my credentials everything works fine.

I am not sure how to display the value of the error block.

Which UI are you using?