Error Update App with aab file


A few weeks ago I updated an app that I already had published on Google Play and there was no problem.

Today I tried to update the app again with an aab file (the other time it was still an apk)

When I upload it, I get an error because the certificate used to sign the app is different.

I have done a test downloading another app made with Thunkable and when updating it I get the same error.

In the error message there are two SHA1, the first is the same in the two errors.

The second SHA1 is diferent in each error

I do not know why it has been changed.

I have uploaded the keystore again, and try again to update but it keeps giving me the same error.

UPDATE 17/06/21

I have done three more tests.

First test

I have downloaded an app that I uploaded to Google Play with an apk and I have tried to update it using an aab.

The only change I have made has been to increase the version code.

When updating I get the same error.

Second test

I had an app downloaded in apk file before this new Thunkable update that had not yet been uploaded on Google Play.

I have downloaded the same app in aab format and have tried to update using both formats.

With the aab format I get the same error.

With the apk format I have no problems.

Third test

I downloaded the same app of the second test using the download option instead publish and I obtained the apk file.

When I upload it, I get the same error of the Other tests.

How can I solve that problem updating apps with the new files generated with Thunkable?

Maybe when the new apps are generated, they have another keystore or SHA1.

Do you think I can use APK Editor Studio for change the keystore or SHA1?

I hope you can help me!


Same issue here when downloading the APK and publishing it to google we get an error stating that the APK or Android Bundle needs to have the same name and the Bundle ID is correct

do you mean it says the Bundle ID is incorrect?

@xandersx57aw @Roberto_Perez_Munoz are you using the exact same Thunkable project for publishing or have you created a copy of your project?

1 Like

I @domhnallohanlon it was the exact same project, so what I did was waited a few hours and tried again and then it seemed to work, I did some tests and found that the error happens when the project tries to save but fails to do so and as a result, adding a new Bundle ID doesn’t update correctly and Google then complains that the BundleID doesn’t match.