Download -> Download Android, feature NOT WORKING!

Hello all
I am a free member and I having a severe issue regarding unable to download the “apk for android”.
After clicked the “Download Android” button and popup message at top right section is not showing. I have tried it many times in past 2 days. And so I waited for hours but didnt get any download mail and the apk didn’t download. Need help asap.

Thanks to all !!

1 Like


Don’t know about the message not showing. Anywho,

Did you check the mail in the Updates session of your inbox?
That is,


Do let me know if that works.

No luck @pathcreator as i think the download message which comes after click “download android” itself didnt appear.

Oof @bhavtoshsharma,

I don’t know what to do about this, so sorry. Maybe other members in the forum will come up with working solutions.


thanks for your time @pathcreator , I hope someone helps me out as i will loose all my data and efforts for the project…

1 Like


I downloaded the apk of one of my projects just now and the message showed just fine:

And I also got the mail in my Updates session:

I guess you should try hard reloading your page?
If that too doesn’t work, you should wait for solutions as I suggested.

@pathcreator .

yes @pathcreator that is the msg that i dont see in either ms edge or chrome !!

1 Like

Did you try hard reloading your page @bhavtoshsharma?

yes @pathcreator but still i dont see “app in queue” msg, i will try restart my laptop later and tell what happens then.

Ok @bhavtoshsharma.

And, any ideas from @codeswept, @domhnallohanlon, @muneer or @catsarisky? Any solutions?

@pathcreator @codeswept, @domhnallohanlon, @muneer or @catsarisky

  1. restarting didnt help
  2. cleaning browser data didnt help
  3. can make changes to my project but when click “download android” nothing happens
  4. i also tried using share feature to get a public URL for my project but i get error popup saying: “Share link generation error. Cannot convert undefined or null to object”

please help !!

1 Like

@pathcreator @codeswept @domhnallohanlon @muneer @catsarisky

I just used “dev tools- inspect” and then clicked download android option of my project and these 3 errors came in the tab console:
/project/buildproject:1 Failed to load resource: the server responded with a status of 520 ()
designer:1 Uncaught (in promise) SyntaxError: Unexpected token < in JSON at position 0
designer:1 Failed to load resource: the server responded with a status of 520 ()

Please help !!

Why are you tagging me? I don’t work for Thunkable!


Oops sorry @catsarisky,

Just thought you’d have better ideas…

I didn’t know that you weren’t working for Thunkable… apologies again!


Does this include clearing the cache?

I think you should better wait for an answer from @Thunkable_Staff

There could be a problem with your project that can only be fixed from Thunkable side.

In the meantime, just try to download any other project to see that this issue is specific to one project.

Again, do not try a lot. The new pricing scheme says free account can only download 2 times a month.


Hi @bhavtoshsharma - is this only happening on one project or all your Thunkable projects?

I can see in the logs that you were able to download a number of times last month, but nothing in the last week or so.

Which browser are you using?

This seems like there’s a bigger issue here as @muneer has suggested…

Can you send on your project link please and I’ll see what we can do about this, thanks!

I can see that you’ve been using Thunkable for a couple of months, but just as a heads-up, this will also apply to existing free accounts from October onwards.


@domhnallohanlon this is happening to a particular one project & yes @muneer i have already downloaded this project 2 times this month BUT shoudnt there be a alert/warning popup msg saying “user has exceeded free downloads for this month!” ?

Sorry i cant even share the public URL as i get error popup saying:
“Share link generation error. Cannot convert undefined or null to object”

Im badly stuck on this issue.

I just need you to copy/paste the link from your browser please.

You can share it here or through a PM.


@domhnallohanlon I didn’t receive a download link yesterday or today either. I am not on a free account and have successfully downloaded once already. (1 out of 25 per month, so far)

I have attempted to download again today and am waiting on the link. I’m assuming that once the app has built that the link will be sent? Is there a notification that is sent when an error occurs during the build process?