Data Source Not Working

I am having a problem with the Data Source. I have selected my data source, it is a Google Sheet. It will not Sync with Source nor will it allow me to select a sheet. This was working last week for me. There are 8 tables in this Google Sheet and I am unable to select none of them.

Hello @bedgepsnq

Could you please try to sync your data source?

To sync your data source please click on it and click the button “Sync with Source”


Let us know if it worked.

I have pressed “Sync with Source” numerous times over the past 4 days, it does not work. I have deleted data sources, created new data sources and the tables in the sheet fail to be recognized. I now have the 1st table in the sheet available but not the other 7 sheets.

Hello @bedgepsnq thank you for sharing more information
Could you please check that all the columns have headers and then try to add the Google sheet again?

Another thing that can cause this issue is merged cells.

I made sure that all the tables in the sheet have column headers in row #1. There are no merged cells. I loaded the Sheet again and I still have the same issue.

Hello @bedgepsnq
Could you please a link for your Google sheet?
You can send it to me as a personal message

i have the same problem airtable in my publish app it dont even load always issues

Hello @kizzy
Please create a different topic for this issue and I will do my best to help you there

@ioannis I do not have any merged cells and the only change I did before the issue occurred was that I moved the data column from one sheet to a new one because I wanted to keep from getting spaces when I wanted to update one column for a list instead of all three when one thing was added. After creating the new tabs is when I ran into the issue. I tried removing and relinking the sheet after the changes and even tried renaming it and attaching it again. I have moved past this now and am updating three Sheets documents instead so I never run into this issue. Honestly I would not be willing to troubleshoot since this would lead to me having to repoint every reference for a third time to the new sheet.

Hello @tobiaskcooperv7vqrm
We can understand that it is frustrating and appreciate you taking the time to investigate and provide more information.
It seems to be an issue when you connect a new Google Sheet with more than one sheet.
We will flag it to our engineering team and will provide an update as soon as possible.
Thank you, again, for your time and patience in this matter.

Hello. I have same problem, after sync google sheet it’s see only one page of the document, but before everything worked well. Tried create new sheet’s, change differently document but anyway it still see only one page and nothing helping. All data bases that we use now is not working. How can i solve this problem?

Hello @descubresancrisj55t @bedgepsnq
Thank you for sharing more information
We have flagged it to our engineering team and will provide an update as soon as possible.

Hello @tobiaskcooperv7vqrm @descubresancrisj55t @bedgepsnq
Thank you again for your patience. I would like to let you know that we have now officially released a fix for this bug.

Please keep in mind that you may need to do a hard refresh of your browser for the changes to take effect in your project.

1 Like

Worked for me with just a Sync of the data source

1 Like