Critical Error Occured

UPDATE - I have tried text input boxes on other projects and I am experiencing the same problem in all of them. Help!

1 Like

Maybe it’s apple’s problem!

i suggest instal NOX android emulator on your pc , and install thunkable live on it , set screen resultion like your iphone and test your app , it will be usefull
Apple support

Can you Screenshot

There is nothing really to screenshot - the project is fine unless you enter something into a text entry field. The moment you tap away from the text entry field, the screen goes white. It no longer responds to anything. I suspect it is an iOS 14.5 issue because the project worked fine before the update.

@domhnallohanlon - any chance you could help look into this?

1 Like

Hey there,

Since this is your own post, did restarting the iOS device work for you?

Hi there,

I have asked the team if they think this behavior could be caused by the iOS 14.5 upgrade, but it does seem unlikely to me since this action - selecting a Text Input then clicking somewhere else on the Screen - doesn’t seem to interact with any major changes that came with iOS 14.5, like the new App Tracking Transparency feature.

If you create a blank app that only contains a Text Input, and test this app on your iOS 14.5 device, do you see the same behavior?

1 Like

I have just updated my iPhone (SE - the old one) to 14.5. I put a textbox on the screen and added an ‘on focus’ event to change a label, using the legacy snap-to-position interface. In Thunkable Live, the app does not crash or otherwise act weird or wipe when the textbox unfocuses.

I also tried the new drag and drop interface and again, nothing unusual seems to happen in Thunkable Live.

Can you share a minimal project that’s acting weirdly?

1 Like

Hi Jane

I tried a new project and the same thing happens. Attached are screenshots of what happens after defocusing (the wiping actually happens very quickly).

As other people don’t seem to have the same problem I am at a loss as to what to do. I have restarted the phone, done a hard reboot of the phone, uninstalled and reinstalled the Thunkable app, all to no avail. I have also downloaded this test app as a freestanding app and the same problem occurs when I defocus text.

Project: Thunkable

1 Like

I tried your project, and I’m not seeing that behavior.

When I click off the text input box, the keyboard smoothly moves downward and goes invisible and the text input box slides down a bit into the space opened up. I tried turning the predictive function on (since I see it in use in your screenshot), but no change.

Which iPhone do you have? My SE (the old version) running 14.5 works fine - it’s slow enough that it there were a weird flicker, I’d expect it to be MORE obvious on my phone…

1 Like

Thanks for trying out the project. I have an iPhone 11 Pro. Everything has worked without a hitch for 5 months until yesterday when this strange behaviour began. I am baffled!

My Problem Solved with going to setting > Apps > thunkable > clear data
and then restarting my phone
i hope your problem be solve too , thanks to thunkable team

1 Like

I updated a device to iOS 14.5 and also do not see this behavior. I tested your app with Thunkable Live and downloaded the app to my iOS device. I hope clearing the app data and restarting the device works for you!

1 Like

Thunkable Live

Version: 266
Created: April 29, 2021 at 06:08AM

1 Like

Unfortunately, I have not been able to fix this problem - I am going to completely wipe my iPhone and reinstall, so hopefully the problem with then go away. Thanks all for the suggestions!

…and after erasing all settings on my iPhone, the thunkable app now works fine again. Phew!


Hi fam,

I’m getting the Critical Error Occured message every time I open up the Thunkable Live app on my Android phone. This is before even selecting an app.

Thunkable Live is working fine on my iPad and iPhone 6S.

I have tried re-installing the app, restarting my phone, clearing the app cache, to no avail.


Something about facebook going on here??

1 Like