Critical error occured in location component

I have been working with location component for past few days and today while live testing it , its showing critical error occurred , I want to know if this is a mistake from my side(my code) or thunkable bug as I saw a couple of other topics related to this issue recently but none of them suggested a solution, do check my code

1 Like

It crashed for my app too. Use latitude + 0 block, and do the same for longitude.

3 Likes

Okay , so should i initialise the longitude and latitude to be 0 at first , are u using the same technique and is your app working

1 Like

@codeswept was saying that the block GetCurrentLocation will return latitude/longitude as text but the block AddMarker expects a number.

A workaround to convert the text to numbers is to add 0 to them which can then be used in the AddMarker.

Hope that makes it clear

Did you mean like this?

1 Like

yes they both mean that

But still I am getting an error

1 Like

what error is it?

Same thing , crtical error occured , its embarrasing and two options relaunch or quit

is it because of the from map code cause when i tried without it , it worked

i think it is problem with starts try using a timer component and set it to 1 second and when it fires then all the blocs you added to when screen starts drop it inside when timer fires

Because you changed in one side and left the other.

Change the last two blocks
from MAP_WHEREAMI set Latitude to and the one after it for longitude both have to have the green block + 0

1 Like

I tried with that but still error

show blocks again

One possibility is that the location sensor encountered an error, use an if block to check if error display alert, else add marker

1 Like

A new version of Thunkable Live came out 3 days ago - does updating solve this issue for you?

@smartnst.tech9d is this live testing on Android or iOS?

Do you have any error handling in your app?

1 Like

I removed the map component and tried adding it again , right now its working perfectly
Thanks for the help

2 Likes