Error With Google Maps

Hi, i need to use a map on my app.

there is a button, when i click on it i need to open maps and localize myself.
But it doesn’t work and appears this message:
“Critical error occurred” with a long details.
I don’t know why.
Can someone help me?
Thank you

Post a link to your project or a screenshot of the blocks you’re using for the map.

https://x.thunkable.com/copy/b6e6c92888eb232bfda2dede1229907a

i tried to uninstall and reinstall thunkable but it doesn’t change.

It’s helpful when you have multiple screens in a project to tell us which screen the blocks are on but I did find them on Screen4.

I believe your project is corrupted somehow. If I Live Test your project, the map does not appear. Even if I add a new Map component, it still appears blank on the screen. If I do the same thing in a different Snap to Place (StP) project, the map appears correctly.

Please try those same blocks in a new blank project and let me know if it works there.

Edit: it could just be that screen that is corrupt. When I add a new screen to your project and add a Map to it, it displays correctly.

Sorry for the mistake about the screen.
I deleted the screen4…now it works fine. There was something strange on screen4.
Solved.

1 Like

Thank you!

Error appears again on screen4 when i insert a map.
Now screen4 shows only a list from data_viewer_list. I would like to start a navigation using google maps when i click on one item of data_viewer_list.

I’ll think you’ll need help from @conroy or other Thunkable Staff. If you deleted the screen and added a new screen and you’re still getting an error with the map, I’m not sure why that is.

Can you post a new share link to your project?

now it works…but i don’t have changed anything

https://x.thunkable.com/copy/3b448c0bc1ca05d82a7a7eb5c61695b8

now the error is about the precision on the map. It is really not accurate…i am in Italy, i add a mark in italy and call a location in Italy but the map send me in America…

You removed the Get Location block so now the lat/long pairs are just from your database. Are you saying that when you provide a lat/long pair in Italy, the marker for it appears in the U.S.?

Can you give an example of a lat/long pair you’re using?

What happens if you type in those same lat/long values as a test to make sure they work for adding a marker without access to your data source?

There is also a bug with the Get Value block so it’s possible you are getting older values that are not current. Try assigning a label’s text to the get value blocks so that you can see if that’s happening.