Can't get blocks to connect together

Everything was working fine earlier. But right now I can’t place certain blocks together. I can hober them over but when I drop them in it makes a click sound but just leaves it behind the block. Anyone also having an issue or seen this before?

@simonwriteclubdi v421 of our platform introduced an update to all blocks, in particular a nice UI refresh and some updated behaviors. It was released within the last hour or so. Can you try a hard refresh of your browser and see if the issue still persists? Thanks so much!

I tried hard refresh and still have same issues. Shall I try again later? Thank you for prompt response.

Could you also send us a screenshot of what you are seeing when you try and connect the blocks? That could also help. Thanks!

You can see the blocks just don’t connect into the gaps and when I lift them into them, it looks like they wil connect but then just drops them back to the transparent view. It’s also very slow on that page and glitchy now

Sorry @simonwriteclubdi, one last request. Could you go to Thunkable and let me know what version it says you’re on. It’ll be at the bottom of the page below Language.

Thunkable Inc. Version v421-1-prod

Appreciate that @simonwriteclubdi, just wanted to make sure it had updated. Our logs can be a bit slow sometimes and those were showing an older version of the Platform being used.

Currently, this is not something we can replicate on our end but I am going to keep an eye out to see if other similar reports come by this evening. It may be something with the browser you’re using or the quality of the internet connection.

Please keep us updated if this is something that continues.

The weird thing is that I’ve tried different browsers, different computers and it isn’t even a problem on different pages. I just logged in when I got home and those blocks have been moved out of their position and made transparent and it won’t let me put them back in. Is this the kind of thing that settles down, or am I best to simply make the whole page again? That is a heck of a lot of work, but equally I don’t want to be sat around for a day doing nothing if that won’t make it any better. Does that make sense? Thanks for your time. Appreciate it.

@simonwriteclubdi My colleague @ioannis noticed this in your blocks–the issue is that those blocks you are trying to place a condition that requires a text equal to a number, which is not possible.

That is why those particular blocks will not go into the math equation blocks.


Ah! Interesting. Yeah, its letting me put things back in without the numbers and using a text box instead with ‘1’ in it. Weird that that was working before. It’s still a bit glitchy but hopefully that will settle down. Will keep you updated if it doesn’t improve. Thank you!!

1 Like

Yes, please keep us updated as you work on this more. We always appreciate the feedback!

1 Like

You can just add zero (0) to a text string to transform it into a number. Or you can compare your text values to “2” instead of 2.

1 Like

Thanks. Will try that out. Managed to get them working again, but I am still having some new issues with speed on a couple of my apps since the UI change yesterday. I probably overuse blocks and can simplify it at times with clone blocks and any component blocks, but definitely noticing much more of a lag at present which is making it hard to work.

I can confirm that since our Blocks update yesterday there are some old combinations of blocks, specifically related to comparing different data types (number vs string, etc.) that are not being allowed to connect anymore.

Thanks matt, that would explain why it was working before. Is there any chance this new update has caused more of a lag on blocks screen? I have a few apps in the making that use lots of blocks and it is a lot of work to cut that down, but yesterday those screens were fine and working well, but today the lag is painful. Im going to try a different internet connection, so will let you know how that goes, but just thought id ask in case anyone else has said something or its just me.

Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.