Can't create rows in airtable

I’m trying to create rows in Airtable. The data source exists, and changes I make directly in Airtable (to the columns and data) reflect in Thunkable when I do ‘Sync with Source.’ My code looks like this, and it’s totally unable to create rows (web preview & live test).


I’m having the same problem! No matter what I do, the new row is not made!

Post a screenshot of your blocks. The most common reason for a create row block not to work is that it’s in a loop that is repeating too quickly. You can also have a bad cell value causing the problem.

1 Like

There is a screenshot of my blocks in the first post in the thread. Is that not showing up for you?

In the mean time, I’ve made a little progress. I’m able to create rows in Airtable if the only fields I have in the table are text fields, and the only thing I try to store in them is from a Thunkable text block. If I have an integer field in Airtable, and try to put a Thunkable math block value there, no row is created.

1 Like

Sorry, @charles.crawfordcu5, my comment was directed at @flaming_mmakers.

Ok. Do you have any advice for me, given that I posted a screenshot and am the originator of the thread?

Should I be able to save values of any type other than text into airtable? Does it require a block structure different to what I’m doing? Does it require a paid account, either with Airtable or Thunkable? I would really love some help here.

1 Like

Heres my code:

1 Like

I don’t use Airtable much but I just did a test. I was able to get a cell so I know the data source is connected properly. I then tried a create row block with a numeric value. This did not work. So I replaced the numeric value with a text string and it worked, creating a new row.

The “create row” block really needs a green error block because otherwise it’s impossible to know why it’s not working.

@charles.crawfordcu5 Your “distances” list has numeric values so you’re going to have to enter them as text values or – easier – convert on the fly by joining each value with an empty string ("") when creating the row.

@flaming_mmakers I feel like your blocks should work but maybe the Photo variable value is causing the problem. Try it first without that.


Currently, the Thunkable connection with Airtable will not allow anything other than text. The create row will fail even if your column in Airtable is email type.

This issue is only in Thunkable and not in Airtable.

1 Like

You definitely should @charles.crawfordcu5 - I’ll have to double-check but hopefully the fix will be out in this week’s release:

1 Like

The issue could be related to airtable wanting to accept string only values?

Think about saving to airtable before these values. You used object blocks that turned everything into a string. A Json string. Then it was sent to airtable. Same idea here maybe?

1 Like

Thank you so much! It’s a bit of a pain that I can’t save images, but at least I can save text. Thanks for the help!

Just wanted to add that I’ve run into the same issue-- only text can be put into a “create row”-- and I’m using a Google sheet, so it is not just airtable.

I can create row with text but not integers. If I code this:

and “secretNumber” has an integer in it, the spreadsheet is not updated. But if I use “join” to convert the variable into text, i.e.,

Then a row gets put into the spreadsheet

Thanks @jared @flaming_mmakers and @David_Wolber, there should be a fix out for this issue later this week. I’ll merge these two topics and notify everyone when it’s out


You can’t upload images, but you can upload them to Cloudinary and then use the URL!