Can't create new Row in Data Sources and Airtable

When I use both of Create row blocks nothing heppens.

It’s first time when I try to add new Row in table, maybe I do somthing wrong.
But it’s look like bug, because in case when I use Airtable Create row block next block (Navigate to) doesn’t work too.

Screenshot_20210309-162721_Samsung Internet

1 Like

Airtable date has a format that you need to follow. You are using the numbers without separators which will not be valid as a date.


Thank you!
But that’s not the reason of the problem :frowning:

1 Like

I checked creating new rows in my tables and there was no problems.


I connect to the table using the Data Sources option and not from the Airtable component. These two connections has different blocks and I think they connect to the tables using different programming codes in the Thunkable platform.

1 Like

It’s strange, because as you can see on my second screenshot, I trying to use Data Sources too (it doesn’t work in my app).

1 Like

Still doesn’t work for new and old projects… for Data source tables and for Air Table. Even when projects absolutely empty (contain just add data button and Data source or Airtable).

Снимок экрана 2021-03-10 в 13.02.04

1 Like

I wonder if you have a total of 1200 rows in your tables. If so, then you reached the limit of free account and you will not be able to add new rows.

Just a thought.

1 Like

Oh, thank you, It’s interesting!
but I use tables with 0-20 rows.

1 Like

Same here, I created an entirely new google account as my usual one was not working at all, nor airtable, nor google sheets.
I made a second one but it stopped working after I changed and deleted some airtables, on this third one I can use google sheets but I can’t create any row in airtable. Very stressing.

1 Like

Hey @andreyandrievich - can you try moving the navigate to block inside the create row block please?

1 Like

Hi! I’ve done this before, but it didn’t solve the problem.

I tried with an old table that had linked fields and it didn’t like that either.

To make testing as easy as possible I’ve created a table with two fields, both of which are text fields

Screenshot 2021-03-11 at 12.35.54

With this set up I’m able to create rows and update rows without any difficulty.

What does this look like in your Airtable @andreyandrievich?

  1. In my Airtable I had 4 columns with text and 1 column with email.
  2. When I deleted the column with email the error disappeared and now I can create new rows in this table. That’s great, thank you so much for that!
  3. I also have a problem with creating rows in the internal database (see screenshot).

Thanks @andreyandrievich - moving this question to it’s own topic since it’s not related to Airtable.

Let’s continue the discussion over here:

Hey @andreyandrievich - just to follow up here, we’ve been able to identify and fix this issue. We need to do some testing first so if it doesn’t make it out in this week’s release it should be available next week.

cc: @testhunk1ti @muneer


Thank you, that’s great!