Buttons stopped working


I’ve been working on a project for 6+ weeks. Last night, the buttons suddenly stopped working. Assuming I had caused it, I went to a project copy and tried buttons there. No joy. I went to projects that I duplicated days and weeks ago and those buttons did not work.

I copied a project from another source and those buttons worked. I created a brand new project with two screens and two buttons and that project’s buttons work just fine.

Any ideas what has happened to my older projects’ buttons? They work in the Preview, but not on the phone app. I’ve tried multiple phones, no joy. I’ve tried downloading an APK, still no joy.

I am at a loss here, I’d appreciate it if anyone could help me out.

Found the problem. I was initializing a list variable with a list of values. Initializing the list variable with “Empty List” fixed the problem. Initializing the variable with a list worked on several project copies until it suddenly didn’t work for the project or any project copy at 1815 hours 8/3/20. Tracked it down by removing Design elements, then a few blocks at a time while running the phone app. :face_with_raised_eyebrow:

Hey @mrtwocanes,

Did you get this issue solved eventually? Just curious do you think this was a bug with the platform or did the app cause itself to break?

Yes, I did and posted the solution. I believe, with no proof, that a change was made that enforces the initialization of a list to be an empty list, instead of trying to initialize it with data. I could be wrong, but that’s what fixed all my projects that had suddenly started failing.

1 Like