Lots in my app has changed even though I didn't change anything

In an app of mine, a lot has stopped working even though it was working an hour previously. I hadn’t changed anything in between.


Now unable to reference a cloned button using the ‘in list get’ block.

This used to work, now it’s not.

A make list from text block doesn’t return anything.

When I try to display move to # in a list viewer, the app crashes. I am unable to fetch any data from this list.

When I try to display a normal variable in a label, I get undefined even though my variable is initialized to 1. Since I hadn’t changed anything, it’s really weird that my app stopped working, and I’d like to find out if there was any downtime today that did it? Or is it something else?


If you’d like, you can send me a link to your project and I can see if it runs okay on my computer.


I’ve managed to do some fiddling and get it slightly better, but I needed to reinitialize the variables when the screen opens (if a variable is initialized to 1, i set it to 1 again when the screen opens).
But I’ll still send you a link.

This simplification worked fine for me:


1 Like

I also tried it at the very bottom of the “when screen opens” block and it previewed fine in a browser:


1 Like

If I run the Any Component blocks, it display “Loading value…” and then takes a while (10+ seconds) to highlight the various number tiles but then it displays the value 1. I’m not sure if that’s correct but it didn’t crash the app.

1 Like

I think this is a bug. I’m initializing variables to a certain value, but unless I reinitialize them when the screen opens (set the variables to the same value), Thunkable does not recognize that there are values inside the variables. You’ll notice that I’m setting app variable move to # to the same value it was initialized to (make list from text). If you delete that set block, you’ll probably find the app crashing too.

It doesn’t crash in a Live Test in a browser if I remove the “set variable move to #” block. This is what I see:

The 1 in the top-left corner is Label1 (see my previous post right above)

1 Like

If I remove the set block, and then click on the dice the app crashes.

Also, I notice that for some reason, I’m getting 2 circles in Label 1 instead of 1. When I display the value of variable color to a label in screen Pawns, then I get only 1.

I hadn’t tried clicking on the dice. When I do that, it crashes. Have you tried setting debug “traps” in the shake function? A trap would be setting a label to a value and then waiting a short amount of time.

So, throughout the function, you’d have:

[a few blocks]
set label1 to “A”
wait 0.5 seconds
[a few blocks]
set label1 to “B”
wait 0.5 seconds
[a few blocks]
set label1 to “C”

That way, if you watch the code, you can see if it’s crashing before “A”, before “B”, before “C” or after “C”. That helps you isolate the cause of the crash.

1 Like

First, I thought the problem was that you were trying to specify a list item number using a text string (the “move to #” list contains text strings:

But I replaced those with numbers and it still crashes. This returns surprising results:

I end up seeing A… 2 (or another number)… B… crash

So it is crashing when trying to take the second value of the variable “move to #” list. That happens even if the list is a series of numbers instead of text strings.

I honestly don’t know what to make of it. I can only explain it one of two ways:

  1. You changed the type of the “move to #” variable (e.g. from a list to text) but I can’t find evidence of that.
  2. The “move to #” variable is corrupt… seems unlikely but maybe try to make a new list variable.

Edit: on second thought, I still think the issue is that you’re using text strings as list item #s.


I don’t think it’s a problem with that specific variable. Thunkable is wiping the values i give when I initialize variables.

Also, the text strings arent a problem. If you put the set move to # block back in the WHEN SCREEN OPENS block, you will find it works properly. I had to reinitialize a lot of variable because their initial values aren’t being retrieved.

I have these 6 variables, and I have to reinitialize them to the same value in order for them to work.

1 Like