Buttons not working when Live Testing in browser

In the live test environment of thinkable ; none of my buttons are reacting and this in all the different screen !!!
If I use the last downloaded version on my Iphone , the App is reacting well .
Is there any reason for it ?

4 Likes

Please hard refresh your browser and try again.

Muneer ; it’s not a local behevior . A colleague of my have the same problem .
The test has been done on Chrome and FireFox

Can you share a link to your project?

I am having this issue too. Made my class very awkward since it was their first look at Thunkable.

@tamasintwoa Again, if you can provide a link to a project where this is happening, we can either verify the issue or help you solve it. I know it’s tempting to read about a problem and state you’re having the exact same issue – and it may be – but sometimes there’s also a simple reason for what you’re seeing.

3 Likes

Hi! The Start Quiz button doesn’t work on the Home Screen when I live test the app. When I click on Preview, the button works but it’s unable to read from the local DB. I’m able to live the app from the My Projects page. Here’s the link of the app: Thunkable

When I preview that project, here’s what happens:

Live Test in Chrome: click Start Quiz button → no response

Edit: I just tried it again after using Thunkable Live and now it works in Chrome, too. How strange!!

Live Test in Thunkable Live on iOS → tap Start Quiz button → navigates to next screen

I would report this to Thunkable staff as it seems to be a bug

3 Likes

Yes, I can confirm that the navigate block has changed and it could be the cause of the issue. I can also confirm that this change is only in the StP UI, the DnD UI does not have the shape change of the navigation block.

1 Like

Hi there,

Can you share a project that demonstrates this behavior?

Are there any particular blocks that fail to execute when a Button is clicked, or are Buttons totally unresponsive for you on the web?

1 Like

create any project in StP (not DnD) with at least two screens, have a button in one screen that navigate to another screen. It should be easy to reproduce.

I tested it. Even the screen name in the navigate block is different. As if the name is superimposed on something under it.

See this example
https://x.thunkable.com/projectPage/61408f13ae05f900d9c96228

Note the following:

  • It does not work for the Live Test option in the design page
  • It works from the Preview button in the design page
  • It works from the Project Detail Page

[Edit]
By saying the navigate button shape is different I mean this
image

Thanks for the detail! I had clicked Preview to test the app and it was working as expected, so I appreciate the clarity.

I added other Buttons to try changing the background color of the Screen, and they also don’t function in the Live Test pop-up window.

Does any set of blocks work as expected for you in this Live Test pop-up window?

1 Like

I believe the issue/bug is intermittent because I tried the label click but nothing is responding and after 5 or 6 trials it worked. Then I tested the button and found it working.

So sometimes it respond to clicks and sometimes not. But when not responding then all blocks I tried are not responding (label, text_input, button, image)

Still on this example: Thunkable

I live test the app using the Live Test option and the Start Quiz Button is navigating to the Score Screen instead of the Quiz Screen. Everything works fine on the Project Detail page.

[Edit]
It goes really briefly to the Quiz Screen then switches to the Score Screen.

2 Likes

The first step in troubleshooting is to work backwards from what you know.

You know that the Quiz Screen is immediately navigating to the Score Screen. So examining your blocks, you can add an indicator (e.g. change a label value and wait) to verify this:

image

Which means that the database value is null when your screen opens. So that’s what you have to figure out now…

3 Likes

Hi! Thanks for pointing out how to troubleshoot. For some reason, it isn’t reading from the local DB during Live Test. The app works fine when I live test it from the Project Detail page.

1 Like

For me, the value of call Quiz DB's GetCell block is null when I preview it in a browser but correct “In computer science and AI…” when I Live Test it in Thunkable Live. I think this is a bug!

1 Like